aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-18 20:23:54 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-18 20:32:56 +0000
commit5ddc0b335e8187f21743eccf8eaa1cd9ec7e700b (patch)
treefcc6b6d2875767613cdb1f6567b2a54b75fc7848 /testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch
parent9ffa2b9c245d7e8f531cbf44d1cc99ba1f2a2b45 (diff)
downloadaports-5ddc0b335e8187f21743eccf8eaa1cd9ec7e700b.tar.bz2
aports-5ddc0b335e8187f21743eccf8eaa1cd9ec7e700b.tar.xz
testing/perl-www-curl: Fix issue on build
Perl-www-curl version 4.17 has an upstream issue that causes the following error: curlopt-constants.c:128:49: error: 'CURL_STRICTER' undeclared (first use in this function) if (strEQ(name, "STRICTER")) return CURL_STRICTER; This was fixed upstream on the following commit: https://anonscm.debian.org/cgit/pkg-perl/packages/libwww-curl-perl.git/commit/?id=d83b9f7 Cherry-picking this patch to Alpine.
Diffstat (limited to 'testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch')
-rw-r--r--testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch b/testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch
new file mode 100644
index 0000000000..e89d237ea2
--- /dev/null
+++ b/testing/perl-www-curl/WWW-Curl-4.17-RT117793.patch
@@ -0,0 +1,25 @@
+From 292c05a8aa9c18bd27d0aaff0b4ee601d9b87b92 Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <cpansand@cvrsnica-freebsd-101.herceg.de>
+Date: Sun, 16 Apr 2017 22:17:00 +0200
+Subject: [PATCH] compilation fixes for curl 7.50.2 and newer (RT #117793)
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f9170bb..bb852e4 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
+ close H;
+
+ for my $e (sort @syms) {
+- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
++ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z)/) {
+ next;
+ }
+ my ($group) = $e =~ m/^([^_]+_)/;
+--
+2.1.2
+