aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pgbouncer
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-19 13:26:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-19 13:26:00 +0000
commit21a1cb18172997ad668ae6fc75f83073cb7d7bd5 (patch)
tree403198de2b26b6f5609dddf71c672bbb2465c37a /testing/pgbouncer
parent8a59e3e6bd29f9f005a391010b7962ba365e54f5 (diff)
downloadaports-21a1cb18172997ad668ae6fc75f83073cb7d7bd5.tar.bz2
aports-21a1cb18172997ad668ae6fc75f83073cb7d7bd5.tar.xz
testing/pgbouncer: rebuild against libressl 2.5
Diffstat (limited to 'testing/pgbouncer')
-rw-r--r--testing/pgbouncer/APKBUILD9
-rw-r--r--testing/pgbouncer/libressl-2.5.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/pgbouncer/APKBUILD b/testing/pgbouncer/APKBUILD
index 38af308884..9a2de5f4cb 100644
--- a/testing/pgbouncer/APKBUILD
+++ b/testing/pgbouncer/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=pgbouncer
pkgver=1.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight connection pooler for PostgreSQL"
url="https://wiki.postgresql.org/wiki/PgBouncer"
arch="all"
@@ -16,7 +16,9 @@ source="https://pgbouncer.github.io/downloads/files/$pkgver/$pkgname-$pkgver.tar
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
- pgbouncer-dirs.patch"
+ pgbouncer-dirs.patch
+ libressl-2.5.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -42,4 +44,5 @@ sha512sums="11c89606599f424b34f39a4b072ec6293fea0b14ee52ae4fbc44775e6d83771a22d1
ecd34f017316b2c0aad172e5bf5393137da5ab841f4d6de93eb82a07abe9f234a2426ca7dada2dc047c33ea4c7dc0af3040b249ec1f9d7e0c1782fb0463a7293 pgbouncer.initd
dbcd7f5860b7f1ec6b6372b718678ba74c5268e89eed0fe291cd292a50460f0e81876367cb86e97f1cfefc0ace8d698c41a313642ec64d2de0747c348665afba pgbouncer.confd
5aa4226ab2d168a88a3b64deb114d3901431d2afb2571cf8ae411c989549bc465ee05104a6863cc8fce6d769d809b4ab536973280f50cb4415c6698c34e1a5b8 pgbouncer.logrotate
-6a475bf5cff10b464177af619051529ad78e802c56655500ad23130c5989721f41592387f9bf6719810eae2d876a8dd36219b87ae1fdb29304b2adc98c49ae4c pgbouncer-dirs.patch"
+6a475bf5cff10b464177af619051529ad78e802c56655500ad23130c5989721f41592387f9bf6719810eae2d876a8dd36219b87ae1fdb29304b2adc98c49ae4c pgbouncer-dirs.patch
+97caf142578f2f9d1500979ce88244554f316f999837707137dc4c3ec6ebc45bcef16678e61fdd1118bf4e26c7df733bd399f4a82b9b5a8e44c3497ab0922524 libressl-2.5.patch"
diff --git a/testing/pgbouncer/libressl-2.5.patch b/testing/pgbouncer/libressl-2.5.patch
new file mode 100644
index 0000000000..8aaae74dbc
--- /dev/null
+++ b/testing/pgbouncer/libressl-2.5.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/usual/tls/tls.c b/lib/usual/tls/tls.c
+index 9c6f6b9..a480fa4 100644
+--- a/lib/usual/tls/tls.c
++++ b/lib/usual/tls/tls.c
+@@ -287,7 +287,7 @@ tls_info_callback(const SSL *ssl, int where, int rc)
+ {
+ struct tls *ctx = SSL_get_app_data(ssl);
+
+-#ifdef USE_LIBSSL_INTERNALS
++#if defined(USE_LIBSSL_INTERNALS) && LIBRESSL_VERSION_NUMBER < 0x2050100fL
+ if (!(ctx->state & TLS_HANDSHAKE_COMPLETE) && ssl->s3) {
+ /* steal info about used DH key */
+ if (ssl->s3->tmp.dh && !ctx->used_dh_bits) {