aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-igbinary
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-05-19 17:01:59 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-05-19 18:04:38 +0300
commit70c09871a19baf8d5e66ea7484c815ea5f2af10f (patch)
tree5ae20c7b24dd449fa10a760b10ad893a0cc0df3d /testing/php7-igbinary
parent71fa4c14b9bc44b725b2e30bb99872cb0781b71f (diff)
downloadaports-70c09871a19baf8d5e66ea7484c815ea5f2af10f.tar.bz2
aports-70c09871a19baf8d5e66ea7484c815ea5f2af10f.tar.xz
testing/php7-igbinary: new aport
Diffstat (limited to 'testing/php7-igbinary')
-rw-r--r--testing/php7-igbinary/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/php7-igbinary/APKBUILD b/testing/php7-igbinary/APKBUILD
new file mode 100644
index 0000000000..380223f962
--- /dev/null
+++ b/testing/php7-igbinary/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+
+pkgname=php7-igbinary
+_pkgreal=igbinary
+pkgver=2.0.6
+pkgrel=0
+pkgdesc="Igbinary is a drop in replacement for the standard php serializer"
+url="https://pecl.php.net/package/igbinary"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends="autoconf php7-dev"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure \
+ --prefix=/usr \
+ --with-php-config=/usr/bin/php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > \
+ "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="56f230e42c155ab6bd309189fc94c09e1e60ce80e111fbb4a66cb977230a19690de84e0e2cbc21a764e053072a2f2a9629fa053c45a5acd649e6010c727b656a igbinary-2.0.6.tgz"