aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-msgpack/APKBUILD
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-06 23:40:22 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:40:08 +0000
commitd0ab7efb0bb9af43f3df05515c5096fbf87d8702 (patch)
tree24f73878dc166ffc4d50181daafe7dbff11dba1f /testing/php7-msgpack/APKBUILD
parent5da3e16a1e83eb0c60c5d44b7864011bb627f172 (diff)
downloadaports-d0ab7efb0bb9af43f3df05515c5096fbf87d8702.tar.bz2
aports-d0ab7efb0bb9af43f3df05515c5096fbf87d8702.tar.xz
testing/php7-msgpack: PHP7 MessagePack package
Diffstat (limited to 'testing/php7-msgpack/APKBUILD')
-rw-r--r--testing/php7-msgpack/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-msgpack/APKBUILD b/testing/php7-msgpack/APKBUILD
new file mode 100644
index 0000000000..a011e1c535
--- /dev/null
+++ b/testing/php7-msgpack/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-msgpack
+_pkgreal=msgpack
+pkgver=2.0.1
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="This extension provide API for communicating with MessagePack serialization."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends="php7-session"
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
+}
+
+md5sums="4d1db4592ffa4101601aefc794191de5 msgpack-2.0.1.tgz"
+sha256sums="d32aeef9af3be6135a06f29e28ec9f386cde9d90ad346a396d9ba8018a7044c6 msgpack-2.0.1.tgz"
+sha512sums="ad567650b93409728d0f9c4bea1812083961b4070d583890a21311e931635fa5252ebf7746ea2d7ee8961f0ea5d86ee04b860a00270b8790bcb3064da7cfd3b9 msgpack-2.0.1.tgz"