aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-decimal
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-02-04 10:24:23 +0200
committerAndy Postnikov <apostnikov@gmail.com>2020-02-04 22:06:23 +0200
commit9d56d67635b6be366a2652d8106d49dad4fcd427 (patch)
tree021880ae43bf7d1382fdddae453a0c4c8fad86fc /testing/php7-pecl-decimal
parentb222fb50c372e3dfcc6775c6a542ccc4159fde5f (diff)
downloadaports-9d56d67635b6be366a2652d8106d49dad4fcd427.tar.bz2
aports-9d56d67635b6be366a2652d8106d49dad4fcd427.tar.xz
testing/php7-pecl-decimal: new aport
Diffstat (limited to 'testing/php7-pecl-decimal')
-rw-r--r--testing/php7-pecl-decimal/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/php7-pecl-decimal/APKBUILD b/testing/php7-pecl-decimal/APKBUILD
new file mode 100644
index 0000000000..440bdc2be1
--- /dev/null
+++ b/testing/php7-pecl-decimal/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-pecl-decimal
+_pkgreal=decimal
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Correctly-rounded arbitrary precision decimal floating-point arithmetic in PHP."
+url="https://pecl.php.net/package/decimal"
+arch="all"
+license="MIT"
+depends="php7-json"
+makedepends="php7-dev re2c mpdecimal"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-decimal=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-decimal" # for backward compatibility
+
+build() {
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test PHP_TEST_SHARED_EXTENSIONS=" \
+ -d extension=/usr/lib/php7/modules/json.so \
+ -d extension=modules/$_pkgreal.so"
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="8e3fa73c875d6b4df09c1a23569abd1487226112e9e91f2e1e02ad8118fc06e5002e4e6f2e16e1ca18b5913faa43e2ac5585f86ef489395e68e573a14de4e45a decimal-1.3.1.tgz"