aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-protobuf
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-26 21:18:28 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-03-27 15:51:13 +0200
commit36cda70436194dc1c977eee95fdd23efa09ec44a (patch)
tree3d1e1755c4aca16b711be15bd2ceae0a2747488a /testing/php7-pecl-protobuf
parentda453c49b9449b98658701cb593721bfd3b78bec (diff)
downloadaports-36cda70436194dc1c977eee95fdd23efa09ec44a.tar.bz2
aports-36cda70436194dc1c977eee95fdd23efa09ec44a.tar.xz
testingphp7-pecl-protobuf: moved from testing/php7-protobuf and added check()
Diffstat (limited to 'testing/php7-pecl-protobuf')
-rw-r--r--testing/php7-pecl-protobuf/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-pecl-protobuf/APKBUILD b/testing/php7-pecl-protobuf/APKBUILD
new file mode 100644
index 0000000000..0ded2c0574
--- /dev/null
+++ b/testing/php7-pecl-protobuf/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=php7-pecl-protobuf
+_pkgreal=protobuf
+pkgver=3.7.0
+pkgrel=1
+pkgdesc="PHP7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
+url="https://pecl.php.net/package/protobuf"
+arch="all"
+license="BSD-3-Clause"
+depends="php7-common"
+makedepends="php7-dev autoconf libtool"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-protobuf" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ # Test suite is not a part of pecl release.
+ php7 -d extension="$builddir"/modules/$_pkgreal.so --ri $_pkgreal
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="8b2772c9b1c0ecd767b4bf0782f1e852c3973c9e436f8cc49857cd277828f972c5db8c8b1d80b6a1b39ddd56e898331d7ee61d101b10577b476f1500f1764098 protobuf-3.7.0.tgz"