aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-stats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-27 16:05:15 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-04-19 02:17:17 +0300
commit2efd1babc8cad782b5ae883dbe9cf14b2d4e086b (patch)
tree53d146a0aa8a6c65da9ac323562b2891e474643b /testing/php7-pecl-stats
parent8a4ebe281981bbdb4d8496758530b068177f3077 (diff)
downloadaports-2efd1babc8cad782b5ae883dbe9cf14b2d4e086b.tar.bz2
aports-2efd1babc8cad782b5ae883dbe9cf14b2d4e086b.tar.xz
testing/php7-pecl-stats: moved from testing/php7-stats
Diffstat (limited to 'testing/php7-pecl-stats')
-rw-r--r--testing/php7-pecl-stats/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/php7-pecl-stats/APKBUILD b/testing/php7-pecl-stats/APKBUILD
new file mode 100644
index 0000000000..3e28481f74
--- /dev/null
+++ b/testing/php7-pecl-stats/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-stats
+_pkgreal=stats
+pkgver=2.0.3
+pkgrel=7
+pkgdesc="Extension that provides few dozens routines for statistical computation."
+url="https://pecl.php.net/package/$_pkgreal"
+arch="all !s390x" # too many tests fails on s390x
+license="PHP-3.01"
+depends=""
+makedepends="php7-dev autoconf"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$pkgver
+provides="php7-stats=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-stats" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ case "$CARCH" in
+ # Remove test fail https://bugs.php.net/bug.php?id=76163
+ aarch64 | ppc64le) rm tests/stats_stat_correlation.phpt
+ esac
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
+}
+
+sha512sums="68a21296f8892c399d961bc1bba31cb6ebf6e0533fd396fc8527a33aa0b7cc189e718bd22dddbaaaeda183488971f02e87b2d9514085cc2a3d0fc558921a584c stats-2.0.3.tgz"