aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-tideways_xhprof
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-02-03 03:34:30 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-02-03 03:34:30 +0200
commit2d7cbaa7a0838d0eab7176e61bbb3874892020f0 (patch)
treefb09611eecdc06d09504313bd4cf5d11b65717db /testing/php7-tideways_xhprof
parentb1e0a9912bf0a1d1eec6e0c405b39a6841132e71 (diff)
downloadaports-2d7cbaa7a0838d0eab7176e61bbb3874892020f0.tar.bz2
aports-2d7cbaa7a0838d0eab7176e61bbb3874892020f0.tar.xz
testing/php7-tideways_xhprof: upgrade to 5.0_beta3
Diffstat (limited to 'testing/php7-tideways_xhprof')
-rw-r--r--testing/php7-tideways_xhprof/APKBUILD8
-rw-r--r--testing/php7-tideways_xhprof/timer_ppc64le.patch15
2 files changed, 3 insertions, 20 deletions
diff --git a/testing/php7-tideways_xhprof/APKBUILD b/testing/php7-tideways_xhprof/APKBUILD
index 3fa11bfd8a..defcc10de5 100644
--- a/testing/php7-tideways_xhprof/APKBUILD
+++ b/testing/php7-tideways_xhprof/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7-tideways_xhprof
_pkgext=tideways_xhprof
_pkgreal=php-xhprof-extension
-pkgver=5.0_beta2
+pkgver=5.0_beta3
_pkgver=${pkgver/_/-}
pkgrel=1
pkgdesc="Modern XHProf compatible Profiler for PHP 7"
@@ -12,8 +12,7 @@ arch="all !armhf !armv7 !aarch64 !s390x" # fails to build
license="Apache-2.0"
depends="php7"
makedepends="php7-dev autoconf"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/$_pkgreal/archive/v$_pkgver.tar.gz
- timer_ppc64le.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/$_pkgreal/archive/v$_pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$_pkgver"
build() {
@@ -38,5 +37,4 @@ package() {
echo "extension=$_pkgext.so" > "$pkgdir"/etc/php7/conf.d/$_pkgext.ini
}
-sha512sums="1e42589b81f39272cf62a058e1ecd82532b076bebe583d13b797d448891ff615aedf1e990785fbba7302daa34a977bf748cf2deaaf4fd334af800a556849334c php7-tideways_xhprof-5.0_beta2.tar.gz
-62f09c950a5b85efd87159e9e747298fd7c9b2bbec060745adf120c5cf5748e4cdfa4625c8b49e15f9905bf3833dab91f81a297e5a68fbb9e3778025846c12b6 timer_ppc64le.patch"
+sha512sums="5b682ed8cda21236c54c3161645620ba06f14478fcf1b45684788b742e47d63419b3e3f74da7d3e376ce5fafeb215ed40d080aaac0c2a8799315f83c877e3110 php7-tideways_xhprof-5.0_beta3.tar.gz"
diff --git a/testing/php7-tideways_xhprof/timer_ppc64le.patch b/testing/php7-tideways_xhprof/timer_ppc64le.patch
deleted file mode 100644
index b70ca08ee9..0000000000
--- a/testing/php7-tideways_xhprof/timer_ppc64le.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/timer.h
-+++ b/timer.h
-@@ -75,8 +75,12 @@
- return 0;
- #endif
- case TIDEWAYS_XHPROF_CLOCK_TSC:
-+#if !defined (__powerpc64__)
- asm volatile("rdtsc" : "=a" (a), "=d" (d));
- (val) = ((uint64)a) | (((uint64)d)<<32);
-+#else
-+ asm volatile ("mftb %0" : "=r" (val));
-+#endif
- return val / timebase_factor;
-
- default: