aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-varnish
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-07-03 00:12:56 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-07-13 19:00:11 +0300
commit41a323ecb6225990dd1f2cde7b360a78b3bdca29 (patch)
treebd617e14e8f69b3eee989edbcbc00a8a1d44957e /testing/php7-varnish
parente85c11c31b26f4038bea2d69494db969d2b54f5f (diff)
downloadaports-41a323ecb6225990dd1f2cde7b360a78b3bdca29.tar.bz2
aports-41a323ecb6225990dd1f2cde7b360a78b3bdca29.tar.xz
testing/php7-varnish: new aport
Diffstat (limited to 'testing/php7-varnish')
-rw-r--r--testing/php7-varnish/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/php7-varnish/APKBUILD b/testing/php7-varnish/APKBUILD
new file mode 100644
index 0000000000..9267fc8e03
--- /dev/null
+++ b/testing/php7-varnish/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-varnish
+_pkgreal=varnish
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="PHP7 extension: makes it possible to interact with a running varnish instance through TCP socket or shared memory."
+url="https://pecl.php.net/package/varnish"
+arch="all"
+license="BSD-3-Clause"
+depends="php7-common"
+makedepends="php7-dev autoconf libtool varnish-dev"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="23c39c432bdd7c932c8096ed7946300d08fd33b6d4445e5025dddcdd669ca707e045fad565e4201e46d14f82659ae34b8efe5178d06bf0d11d0755b14eb48fed varnish-1.2.4.tgz"