aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-zmq
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-07 00:03:24 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:40:53 +0000
commitdd74a3fe4963ae23cd38596b8d0e3d5279aabb8d (patch)
treed8f204ea3bd77ffc33a742b58770cca8129daa46 /testing/php7-zmq
parentd0ab7efb0bb9af43f3df05515c5096fbf87d8702 (diff)
downloadaports-dd74a3fe4963ae23cd38596b8d0e3d5279aabb8d.tar.bz2
aports-dd74a3fe4963ae23cd38596b8d0e3d5279aabb8d.tar.xz
testing/php7-zmq: PHP7 ZeroMQ package
Diffstat (limited to 'testing/php7-zmq')
-rw-r--r--testing/php7-zmq/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-zmq/APKBUILD b/testing/php7-zmq/APKBUILD
new file mode 100644
index 0000000000..f7c5ebf85b
--- /dev/null
+++ b/testing/php7-zmq/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-zmq
+_pkgreal=zmq
+pkgver=1.1.3
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="ZeroMQ is a software library that lets you quickly design and implement a fast message-based applications."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf zeromq-dev"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
+}
+
+md5sums="9c638df5a6347a0fefb0d43d780e6480 zmq-1.1.3.tgz"
+sha256sums="c492375818bd51b355352798fb94f04d6828c6aeda41ba813849624af74144ce zmq-1.1.3.tgz"
+sha512sums="0f03016e315a6c6a1e1d6eca1e20564834d2a924cef06af1b38693933f1e5a094c37e9c432705a64f61d95e82655f61358fc7783e7a6f06c7dd9ad84fc6f7bbc zmq-1.1.3.tgz"