aboutsummaryrefslogtreecommitdiffstats
path: root/testing/phpredis
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@me.com>2015-03-18 14:48:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-19 12:02:43 +0000
commit9b446dd7bf9a5a741b7c32028da0ef54315c89ae (patch)
tree92fd0a5a7033f0606e3ad0d55ebf50bc4a5903aa /testing/phpredis
parentfba418bcbac68007164daf6f681e67d765885adf (diff)
downloadaports-9b446dd7bf9a5a741b7c32028da0ef54315c89ae.tar.bz2
aports-9b446dd7bf9a5a741b7c32028da0ef54315c89ae.tar.xz
testing/phpredis: new aport
The phpredis extension provides an API for communicating with the Redis key-value store https://github.com/phpredis/phpredis
Diffstat (limited to 'testing/phpredis')
-rw-r--r--testing/phpredis/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/phpredis/APKBUILD b/testing/phpredis/APKBUILD
new file mode 100644
index 0000000000..e63f7ef70f
--- /dev/null
+++ b/testing/phpredis/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: ScrumpyJack <scrumpyjack@me.com>
+# Maintainer:
+pkgname=phpredis
+pkgver=2.2.7
+pkgrel=0
+pkgdesc="The phpredis extension provides an API for communicating with the Redis key-value store"
+url="https://github.com/phpredis/phpredis"
+arch="all"
+license="PHP"
+depends=""
+depends_dev=""
+makedepends="php-dev autoconf"
+install=""
+subpackages=""
+source="https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize
+ ./configure
+}
+
+package() {
+ cd "$_builddir"
+ make || return 1
+ make INSTALL_ROOT=$pkgdir install || return 1
+}
+
+md5sums="f10bada46b6e1a15eac613df4f298f51 2.2.7.tar.gz"
+sha256sums="a5882dd9b21908e123b3d5c5f72d6dc8cbbbb6a29996e568c4d18ed356c0362b 2.2.7.tar.gz"
+sha512sums="eddca71c76fc39f46a316ac204521f352cba30cb2999a7b91fe907bdb0f17e287be025df2f7c3b7115790b1c2a781c162b32c77d29daf30b246bd4d163e5404e 2.2.7.tar.gz"