aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pipewire
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-21 11:20:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-21 11:20:52 -0300
commitad637c7d0f792333c40096843275a447204eae7c (patch)
tree12d09722a64086add22a8cac655930b6125e1f63 /testing/pipewire
parent11157689c8ae3d32391aa32c8ecb41703ba8cd5e (diff)
downloadaports-ad637c7d0f792333c40096843275a447204eae7c.tar.bz2
aports-ad637c7d0f792333c40096843275a447204eae7c.tar.xz
testing/pipewire: fix s390x
Diffstat (limited to 'testing/pipewire')
-rw-r--r--testing/pipewire/APKBUILD7
-rw-r--r--testing/pipewire/fix-s390x.patch17
2 files changed, 22 insertions, 2 deletions
diff --git a/testing/pipewire/APKBUILD b/testing/pipewire/APKBUILD
index 328a5c1c73..8117ea7b8e 100644
--- a/testing/pipewire/APKBUILD
+++ b/testing/pipewire/APKBUILD
@@ -12,7 +12,9 @@ makedepends="meson alsa-lib-dev libx11-dev sdl2-dev ffmpeg-dev eudev-dev dbus-de
options="!check" # no tests
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/PipeWire/pipewire/archive/${pkgver}.tar.gz
- fix-glibc-error_h-usage.patch"
+ fix-glibc-error_h-usage.patch
+ fix-s390x.patch
+ "
build() {
meson \
@@ -34,4 +36,5 @@ package() {
}
sha512sums="3d1db41f5beb42a0ee15ae7bc8afb89b54a37c3a6a414e88b5e33ceaf98ec6dda0d9a2d03ac47a8dfce48e9637e647291919e6670bb70589b0d1951fbcbd3ff8 pipewire-0.2.6.tar.gz
-9c6ab4827c55c6aa26e5070e58a79c7054982e9a5c8ec59ff3ed21474338b1356f49555588f2c3cf40bdc17952835e313149eadb001153bf97bb8360191febd5 fix-glibc-error_h-usage.patch"
+9c6ab4827c55c6aa26e5070e58a79c7054982e9a5c8ec59ff3ed21474338b1356f49555588f2c3cf40bdc17952835e313149eadb001153bf97bb8360191febd5 fix-glibc-error_h-usage.patch
+576a6fbb7d457bda70822a175a188b6f9dbf3b5cf9efa660e458f6d54ff6b88376821164534ec073f20b929d81c2232783f63612fc9ec5803bfe23356449f314 fix-s390x.patch"
diff --git a/testing/pipewire/fix-s390x.patch b/testing/pipewire/fix-s390x.patch
new file mode 100644
index 0000000000..f1a31b40d0
--- /dev/null
+++ b/testing/pipewire/fix-s390x.patch
@@ -0,0 +1,17 @@
+diff --git a/src/modules/module-protocol-native.c b/src/modules/module-protocol-native.c
+index 131657f..7b56863 100644
+--- a/src/modules/module-protocol-native.c
++++ b/src/modules/module-protocol-native.c
+@@ -58,6 +58,11 @@
+ #define UNIX_PATH_MAX 108
+ #endif
+
++/* Required for s390x */
++#ifndef SO_PEERSEC
++#define SO_PEERSEC 31
++#endif
++
+ static bool debug_messages = 0;
+
+ #define LOCK_SUFFIX ".lock"
+