aboutsummaryrefslogtreecommitdiffstats
path: root/testing/plasma-browser-integration
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-22 22:51:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-22 17:54:45 -0300
commitf8587c5d534c85cc1a9561ceb1f7354f01e655ed (patch)
tree05ac7b6734127f0f2100c8f5c794852065267f90 /testing/plasma-browser-integration
parent5eb182121f4bbbfd9987dc8e8aa7a9bfb55618a1 (diff)
downloadaports-f8587c5d534c85cc1a9561ceb1f7354f01e655ed.tar.bz2
aports-f8587c5d534c85cc1a9561ceb1f7354f01e655ed.tar.xz
testing/plasma-browser-integration: new aport
Diffstat (limited to 'testing/plasma-browser-integration')
-rw-r--r--testing/plasma-browser-integration/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/plasma-browser-integration/APKBUILD b/testing/plasma-browser-integration/APKBUILD
new file mode 100644
index 0000000000..aa1629c76f
--- /dev/null
+++ b/testing/plasma-browser-integration/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-browser-integration
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
+arch="all"
+url="https://community.kde.org/Plasma/Browser_Integration"
+license="GPL-3.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="5498b7a483d745db31ebfd5e4f3d2ed441d9c7aea268313482bdf4abf7097fc3939c2da34ff890878d6fcfb2eb60b3ab518c05a39f2c947616e3e05131e5ce2e plasma-browser-integration-5.16.1.tar.xz"