aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pmbootstrap/APKBUILD
diff options
context:
space:
mode:
authorOliver Smith <ollieparanoid@postmarketos.org>2020-01-06 05:09:42 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-27 20:58:28 +0100
commit5f87e07c732265d7ec1d406c3316fdbfc4f602f5 (patch)
tree002b8ecb011c8f6671b003d915a2672b187bc018 /testing/pmbootstrap/APKBUILD
parent6437555d0d0c1ab2bae149f7424fe2f1a45c77bf (diff)
downloadaports-5f87e07c732265d7ec1d406c3316fdbfc4f602f5.tar.bz2
aports-5f87e07c732265d7ec1d406c3316fdbfc4f602f5.tar.xz
testing/pmbootstrap: new aport
Diffstat (limited to 'testing/pmbootstrap/APKBUILD')
-rw-r--r--testing/pmbootstrap/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/pmbootstrap/APKBUILD b/testing/pmbootstrap/APKBUILD
new file mode 100644
index 0000000000..6c02d6a63d
--- /dev/null
+++ b/testing/pmbootstrap/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
+pkgname=pmbootstrap
+pkgver=1.14.0
+pkgrel=0
+pkgdesc="Sophisticated chroot/build/flash tool to develop and install postmarketOS"
+url="https://gitlab.com/postmarketOS/pmbootstrap"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3 coreutils procps openssl"
+checkdepends="pytest"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/postmarketos/pmbootstrap/-/archive/$pkgver/pmbootstrap-$pkgver.tar.gz
+ modules-load.conf"
+install="$pkgname.post-install"
+options="!check" # Tests require chroot etc.
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 "$srcdir"/modules-load.conf "$pkgdir"/etc/modules-load.d/pmbootstrap.conf
+}
+sha512sums="2531539a37c5c37c1731b3ffb51140e35585489aca5b946b0949a67b0d74620b96a16c8943a69a59e302a537d222424778157ec6f0282d7f7474361f3c20446b pmbootstrap-1.14.0.tar.gz
+f8026ab32234b885e69252459047f70160c54319113bc449000aa7c05bd016f00a46cee05c8f5251682f967ab44a12c06fbbb3c02d0a57ccb836cff810ce1a40 modules-load.conf"