aboutsummaryrefslogtreecommitdiffstats
path: root/testing/podman-compose/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-06 17:20:15 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-06 14:59:30 -0300
commit4f64338a189c9e64846f64494f683b33d0f265fe (patch)
treed2371e2aab44188e73beaa1afff2c572dd7cc8a3 /testing/podman-compose/APKBUILD
parent1eda9af8162d5bf3a95880c38a97aa61cdce0e22 (diff)
downloadaports-4f64338a189c9e64846f64494f683b33d0f265fe.tar.bz2
aports-4f64338a189c9e64846f64494f683b33d0f265fe.tar.xz
testing/podman-compose: new aport
Diffstat (limited to 'testing/podman-compose/APKBUILD')
-rw-r--r--testing/podman-compose/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/podman-compose/APKBUILD b/testing/podman-compose/APKBUILD
new file mode 100644
index 0000000000..3e40ccc915
--- /dev/null
+++ b/testing/podman-compose/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=podman-compose
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="A script to run docker-compose.yml using podman"
+url="https://github.com/containers/podman-compose"
+arch="noarch"
+license="GPL-2.0-or-later"
+options="!check" # Requires running docker env
+depends="podman python3 py3-yaml"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/containers/podman-compose/archive/v$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3a5fd56b5394ada0ca465d2cac2249601bb72b20793106d625953e94f55ac19e65d7cd181bbc685fe5de0ac2a7169f0e5f4726e04ff927073eb656c9462c8606 podman-compose-0.1.5.tar.gz"