aboutsummaryrefslogtreecommitdiffstats
path: root/testing/podman/APKBUILD
diff options
context:
space:
mode:
authorKohei Nishimura <kohnish@gmx.com>2019-12-28 12:32:16 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-28 14:44:09 +0100
commita91a498d91172b1b90491f1d8e2a38ea32e1ca1d (patch)
tree7d69b57f3a293d9edeb6667c518872226e47303f /testing/podman/APKBUILD
parent977b50e1a37c2e7521aadbd6aebc8505783fe814 (diff)
downloadaports-a91a498d91172b1b90491f1d8e2a38ea32e1ca1d.tar.bz2
aports-a91a498d91172b1b90491f1d8e2a38ea32e1ca1d.tar.xz
testing/podman: new aports
Diffstat (limited to 'testing/podman/APKBUILD')
-rw-r--r--testing/podman/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/podman/APKBUILD b/testing/podman/APKBUILD
new file mode 100644
index 0000000000..da53a667bf
--- /dev/null
+++ b/testing/podman/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor:
+# Maintainer:
+pkgname=podman
+pkgver=1.6.4
+pkgrel=0
+pkgdesc="Library and tool for running OCI-based containers in Pods"
+options="!check" # TODO: enable tests
+url="https://github.com/containers/libpod"
+arch="all"
+license="Apache-2.0"
+makedepends="go gpgme-dev libseccomp-dev libassuan-dev go-md2man btrfs-progs-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/containers/libpod/archive/v$pkgver.tar.gz"
+builddir="$srcdir/libpod-$pkgver"
+
+build() {
+ unset LDFLAGS
+ make PREFIX=/usr
+}
+
+package() {
+ unset LDFLAGS
+ make install.bin PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+sha512sums="69322551ab196cd3859e03988178c59a47df6f00ef0768a56e40d785f6b2130df03ff0ea76d101e21e748ea9260ede144d31f3ec21922ffd70eb2969a77d4194 podman-1.6.4.tar.gz"