aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:46:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:46:06 +0200
commitb309c535d8516992b6cace4037c992441da8d670 (patch)
treee2e375c72b15e14d5619e36eeb0de973619507d4 /testing/ponyc/APKBUILD
parentc77464fda48424214fe84bdde2d8b14894dcde74 (diff)
downloadaports-b309c535d8516992b6cace4037c992441da8d670.tar.bz2
aports-b309c535d8516992b6cace4037c992441da8d670.tar.xz
Revert "testing/ponyc: don't pass -march and -mtune to gcc"
This reverts commit c77464fda48424214fe84bdde2d8b14894dcde74. This was a mistake.
Diffstat (limited to 'testing/ponyc/APKBUILD')
-rw-r--r--testing/ponyc/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 6d250d0059..04fd912dca 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ponyc
pkgver=0.21.3
-pkgrel=1
+pkgrel=0
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
url="https://www.ponylang.org"
arch="x86_64" # TODO: enable aarch64, armhf
@@ -13,26 +13,22 @@ checkdepends="libressl-dev pcre2-dev"
makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz
+ makefile-no-mtune.patch
fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
-# arch per gcc, used only to define PONY_ARCH.
_arch="$CARCH"
case "$CARCH" in
x86_64) _arch=x86-64;;
- armhf) _arch=armv6zk;;
+ arm*) _arch=armv7;;
esac
-# *_FLAGS= are here to avoid -march and -mtune passed to gcc.
_make_opts="arch=$_arch
config=release
default_pic=1
prefix=/usr
verbose=1
LLVM_CONFIG=/usr/lib/llvm$_llvmver/bin/llvm-config
- BUILD_FLAGS=
- LINKER_FLAGS=
- LL_FLAGS=
"
build() {
@@ -83,4 +79,5 @@ dev() {
}
sha512sums="f89389142d77e93038c77d3fbe9e64c13ce76b9737430969fcdf2916023d0b7195f4d551895eab999798594352b40848be8dcc63af6927e8cc62b7c7000be65d ponyc-0.21.3.tar.gz
+2bb535b0dad3ea9aab02192c131980e5363db348bdc7f993a8e52d08fb5b08223d93c0713a9c1d420844545b5528b80403b9fdba3e0c34dd59f13366db9088c7 makefile-no-mtune.patch
46c0125b60cd1db89d7ae958602b087acb2ae1fd8298cd9141828999693a9e39b60d2dac338853406081fc1c138e506243357618197ffd118fe4ac9737bd1565 fix-tests.patch"