aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc/makefile-remove-march-mtune.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:52:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:56:37 +0200
commitd4c1b9ad854296a4cf75ef68fbe7f8be0916a024 (patch)
tree5408a98b5d380322408968ee473910e795536c56 /testing/ponyc/makefile-remove-march-mtune.patch
parentb309c535d8516992b6cace4037c992441da8d670 (diff)
downloadaports-d4c1b9ad854296a4cf75ef68fbe7f8be0916a024.tar.bz2
aports-d4c1b9ad854296a4cf75ef68fbe7f8be0916a024.tar.xz
testing/ponyc: don't pass -march and -mtune to gcc
Diffstat (limited to 'testing/ponyc/makefile-remove-march-mtune.patch')
-rw-r--r--testing/ponyc/makefile-remove-march-mtune.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/ponyc/makefile-remove-march-mtune.patch b/testing/ponyc/makefile-remove-march-mtune.patch
new file mode 100644
index 0000000000..dfdbfa2959
--- /dev/null
+++ b/testing/ponyc/makefile-remove-march-mtune.patch
@@ -0,0 +1,25 @@
+Don't hassle with -march and -mtune, use gcc defaults.
+
+--- a/Makefile
++++ b/Makefile
+@@ -90,9 +90,9 @@
+ destdir ?= $(prefix)/lib/pony/$(tag)
+
+ LIB_EXT ?= a
+-BUILD_FLAGS = -march=$(arch) -mtune=$(tune) -Werror -Wconversion \
++BUILD_FLAGS = -Werror -Wconversion \
+ -Wno-sign-conversion -Wextra -Wall
+-LINKER_FLAGS = -march=$(arch) -mtune=$(tune)
++LINKER_FLAGS =
+ AR_FLAGS ?= rcs
+ ALL_CFLAGS = -std=gnu11 -fexceptions \
+ -DPONY_VERSION=\"$(tag)\" -DLLVM_VERSION=\"$(llvm_version)\" \
+@@ -102,7 +102,7 @@
+ -DPONY_VERSION_STR=\"$(version_str)\" \
+ -D_FILE_OFFSET_BITS=64
+ ALL_CXXFLAGS = -std=gnu++11 -fno-rtti
+-LL_FLAGS = -mcpu=$(arch)
++LL_FLAGS =
+
+ # Determine pointer size in bits.
+ BITS := $(bits)