aboutsummaryrefslogtreecommitdiffstats
path: root/testing/portmidi/30-porttime_cmake.patch
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-02-21 16:33:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-02-28 12:53:05 +0000
commit24cdbb59afb3e0141401a09cc98c918283ccdc49 (patch)
treec18c934ec904845e8c95d4f52137960751faeec0 /testing/portmidi/30-porttime_cmake.patch
parent478a4a468ecf31c263b6c76dfab0f2332bc3365f (diff)
downloadaports-24cdbb59afb3e0141401a09cc98c918283ccdc49.tar.bz2
aports-24cdbb59afb3e0141401a09cc98c918283ccdc49.tar.xz
testing/portmidi: new aport
http://portmedia.sourceforge.net/ PortMidi is a platform independent library for MIDI input/output.
Diffstat (limited to 'testing/portmidi/30-porttime_cmake.patch')
-rw-r--r--testing/portmidi/30-porttime_cmake.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/portmidi/30-porttime_cmake.patch b/testing/portmidi/30-porttime_cmake.patch
new file mode 100644
index 0000000000..f03e33fcae
--- /dev/null
+++ b/testing/portmidi/30-porttime_cmake.patch
@@ -0,0 +1,32 @@
+diff --git a/porttime/CMakeLists.txt b/porttime/CMakeLists.txt
+new file mode 100644
+index 0000000..7c4da89
+--- /dev/null
++++ b/porttime/CMakeLists.txt
+@@ -0,0 +1,13 @@
++if(UNIX)
++ list(APPEND LIBSRC ptlinux)
++ set(PM_NEEDED_LIBS pthread asound)
++ add_library(porttime SHARED ${LIBSRC})
++ set_target_properties(porttime PROPERTIES VERSION "0.0.0" SOVERSION "0")
++ target_link_libraries(porttime ${PM_NEEDED_LIBS})
++ add_library(porttime-static ${LIBSRC})
++ set_target_properties(porttime-static PROPERTIES OUTPUT_NAME "porttime")
++ target_link_libraries(porttime-static ${PM_NEEDED_LIBS})
++ INSTALL(TARGETS porttime porttime-static
++ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}")
++endif(UNIX)
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4919b78..08301a0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,6 +74,8 @@
+
+ add_subdirectory(pm_dylib)
+
++add_subdirectory(porttime)
++
+ # Cannot figure out how to make an xcode Java application with CMake
+ add_subdirectory(pm_java)
+