aboutsummaryrefslogtreecommitdiffstats
path: root/testing/postgresql-bdr-extension
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-03-12 09:23:36 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-03-12 09:24:50 +0000
commitbf27f7526a4500882c205d2b82bad7cc5eeba6d6 (patch)
tree91ef8be7bfb536175545b4bcfe0aa1b106ea6d61 /testing/postgresql-bdr-extension
parentbea27cd485c3a9064c48c949edd32385333b9b80 (diff)
downloadaports-bf27f7526a4500882c205d2b82bad7cc5eeba6d6.tar.bz2
aports-bf27f7526a4500882c205d2b82bad7cc5eeba6d6.tar.xz
testing/postgresql-bdr-extension: new aport
PostgreSQL bidirectional replication extension
Diffstat (limited to 'testing/postgresql-bdr-extension')
-rw-r--r--testing/postgresql-bdr-extension/APKBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/testing/postgresql-bdr-extension/APKBUILD b/testing/postgresql-bdr-extension/APKBUILD
new file mode 100644
index 0000000000..3b3646583d
--- /dev/null
+++ b/testing/postgresql-bdr-extension/APKBUILD
@@ -0,0 +1,64 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=postgresql-bdr-extension
+pkgver=0.8.0
+pkgrel=0
+_gitcommit=
+_gittag="bdr-plugin/$pkgver"
+_giturl="git://git.postgresql.org/git/2ndquadrant_bdr.git"
+_gitbranch="bdr-plugin/stable"
+[ -z "${_gitcommit}" ] && _suffix="_src" || _suffix="${_gitcommit}"
+pkgdesc="PostgreSQL bidirectional replication (BDR) extension"
+url="https://wiki.postgresql.org/wiki/BDR_Administration"
+arch="x86_64"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev postgresql-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://distfiles.alpinelinux.org/distfiles/$pkgname-$pkgver-$_suffix.tar.bz2"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+snapshot() {
+ mkdir -p "$srcdir"
+ cd "${SRCDEST:-$srcdir}"
+ if ! [ -d $pkgname.git ]; then
+ git clone --bare --branch $_gitbranch $_giturl $pkgname.git || return 1
+ cd $pkgname.git
+ else
+ cd $pkgname.git
+ git fetch || return 1
+ fi
+ git archive --prefix=$pkgname-$pkgver/ -o "$SRCDEST"/$pkgname-$pkgver-$_suffix.tar $_gittag
+ rm "$SRCDEST"/$pkgname-$pkgver-$_suffix.tar.bz2
+ bzip2 "$SRCDEST"/$pkgname-$pkgver-$_suffix.tar
+}
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="03aa1e08f8d226315c6227c4fb674f24 postgresql-bdr-extension-0.8.0-_src.tar.bz2"
+sha256sums="dce9c15331911fb34fd8f5c35fab2e13125e3ef1f0c8e6e10702b1be3b7d5ab9 postgresql-bdr-extension-0.8.0-_src.tar.bz2"
+sha512sums="f41f1053e6ca660c4c695ee7f398318518b28bf23670435dc6a7dcbb8d91162f6f79822f2e52cdd33656dc8b26fcc8f0cbecad47c553afa34e22f4df40abe387 postgresql-bdr-extension-0.8.0-_src.tar.bz2"