aboutsummaryrefslogtreecommitdiffstats
path: root/testing/powerline-extra-symbols
diff options
context:
space:
mode:
authorOrson Teodoro <orsonteodoro@hotmail.com>2018-02-08 11:02:47 -0800
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 22:58:24 +0000
commit5869e1f13a8de4ffa909bbccf51f995d425b25e8 (patch)
tree1c51a06c6c445830c7a138d2a2a5b49471039381 /testing/powerline-extra-symbols
parentfb1ff333b1a58cd2497be2198d979d5f0200bb66 (diff)
downloadaports-5869e1f13a8de4ffa909bbccf51f995d425b25e8.tar.bz2
aports-5869e1f13a8de4ffa909bbccf51f995d425b25e8.tar.xz
testing/powerline-extra-symbols: new aport
fix checksum remove || return 1 reoder default_doc remove doc(), remove unpack(), use install cmd, remove extra newlines. remove makedepends= remove extra new line. add check commit no upstream unit test. force 80 columns
Diffstat (limited to 'testing/powerline-extra-symbols')
-rw-r--r--testing/powerline-extra-symbols/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/powerline-extra-symbols/APKBUILD b/testing/powerline-extra-symbols/APKBUILD
new file mode 100644
index 0000000000..39c8d3376b
--- /dev/null
+++ b/testing/powerline-extra-symbols/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+
+pkgname=powerline-extra-symbols
+pkgver=0_git20171017
+pkgrel=0
+pkgdesc="Extra glyphs for your powerline separators"
+url="https://github.com/ryanoasis/powerline-extra-symbols"
+arch="noarch"
+license="MIT"
+depends="fontconfig"
+subpackages="$pkgname-doc"
+options="!check" # upstream has no unit test
+_gitrev="7fa9262caf89c500d6024313d35f0571c90aae79"
+source="$pkgname-$pkgver.zip::https://github.com/ryanoasis/$pkgname/archive/$_gitrev.zip"
+builddir="$srcdir/"$pkgname-$_gitrev
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir"/usr/share/fonts/$pkgname \
+ "$pkgdir"/usr/share/doc/$pkgname/
+ install -t "$pkgdir"/usr/share/fonts/$pkgname/ \
+ "$builddir"/PowerlineExtraSymbols.otf
+ install -t "$pkgdir"/usr/share/doc/$pkgname/ "$builddir"/README.md
+}
+
+sha512sums="8d0205a843ca2fbe9ba3ab174be2e3d94b132caa60df9b19de49dd23a2d715dccb60198272a55ceb4333fc4441649f5d12426c7aa381254b34149528396fddec powerline-extra-symbols-0_git20171017.zip"