aboutsummaryrefslogtreecommitdiffstats
path: root/testing/powerpc-utils
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-02-09 16:37:08 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-02-12 18:16:11 +0100
commited291e6970b3d2346311bfdcb4fe395bccf1a35d (patch)
tree69d64cd6ce2aff7fa6f09b35c2a585cc013049cd /testing/powerpc-utils
parent298d05c9edc9896f45f0db53bbdd4c447af16527 (diff)
downloadaports-ed291e6970b3d2346311bfdcb4fe395bccf1a35d.tar.bz2
aports-ed291e6970b3d2346311bfdcb4fe395bccf1a35d.tar.xz
testing/powerpc-utils: new aport
This package contains utilities which are intended for maintenance of IBM powerpc platforms that follow the POWER Architecture Platform Reference (PAPR). This build was tested on ppc64le and amd64 arches.
Diffstat (limited to 'testing/powerpc-utils')
-rw-r--r--testing/powerpc-utils/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/powerpc-utils/APKBUILD b/testing/powerpc-utils/APKBUILD
new file mode 100644
index 0000000000..e514f48687
--- /dev/null
+++ b/testing/powerpc-utils/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=powerpc-utils
+pkgver=1.3.3
+pkgrel=0
+pkgdesc="Utilities which are intended for maintenance of powerpc platforms"
+url="https://github.com/nfont/powerpc-utils"
+arch="ppc64le"
+license="GPL"
+makedepends="autoconf automake zlib-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nfont/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./autogen.sh || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --without-librtas \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="26c80f0d0ec886efa1530233f178463e powerpc-utils-1.3.3.tar.gz"
+sha256sums="2a3f4e7ef219d4de642c7da100d7d6511e93556778c0814b2ebc1170256fc844 powerpc-utils-1.3.3.tar.gz"
+sha512sums="cdd7c355b5fd7aa11f717282bad8a03e553249ca104018519faf72a36753e1ac2f6347af3d65acaadbffd0906fd5835d8b6a49dbd545d0a2519b26cbaf9d96ae powerpc-utils-1.3.3.tar.gz"