aboutsummaryrefslogtreecommitdiffstats
path: root/testing/prayer
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-24 00:16:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-24 00:18:22 +0200
commit55615d5b780b6f525347931dd3c10065c0e46864 (patch)
tree7d7e561a215202436f3f165d6ea85620e059b0f0 /testing/prayer
parent0a7fd753bc3856c552bb4fde2a66f7fdd6c94815 (diff)
downloadaports-55615d5b780b6f525347931dd3c10065c0e46864.tar.bz2
aports-55615d5b780b6f525347931dd3c10065c0e46864.tar.xz
testing/prayer: improve abuild and fix code-style
Diffstat (limited to 'testing/prayer')
-rw-r--r--testing/prayer/APKBUILD52
1 files changed, 20 insertions, 32 deletions
diff --git a/testing/prayer/APKBUILD b/testing/prayer/APKBUILD
index 04b27a9e74..80c91bf168 100644
--- a/testing/prayer/APKBUILD
+++ b/testing/prayer/APKBUILD
@@ -1,45 +1,33 @@
-# Maintainer:
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-
+# Maintainer:
pkgname=prayer
pkgver=1.3.5
pkgrel=1
-pkgdesc='Lightweight webmail interface for IMAP servers'
-url='http://www-uxsup.csx.cam.ac.uk/~dpc22/prayer/'
-arch=all
-license=GPL
-depends=
-makedepends='perl imap-dev openssl-dev db-dev linux-pam-dev tar tidyhtml-dev>=5.0.0'
-subpackages=
+pkgdesc="Lightweight webmail interface for IMAP servers"
+url="http://www-uxsup.csx.cam.ac.uk/~dpc22/prayer/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="perl imap-dev openssl-dev db-dev linux-pam-dev tar tidyhtml-dev>=5.0.0"
source="ftp://ftp.csx.cam.ac.uk/pub/software/email/prayer/prayer-$pkgver.tar.gz
- buildfix.patch
- disable_ssl3.patch
- makefile_install_config.patch
- no_db_version_check.patch
- htmltidy_buffio.patch
- sighandling.patch
- unbrand_accountd.patch
- unbrand_cam_template.patch"
-
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
-
- local i
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ buildfix.patch
+ disable_ssl3.patch
+ makefile_install_config.patch
+ no_db_version_check.patch
+ htmltidy_buffio.patch
+ sighandling.patch
+ unbrand_accountd.patch
+ unbrand_cam_template.patch"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$srcdir"/$pkgname-$pkgver
- make || return 1
+ cd "$builddir"
+ make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- BROOT="$pkgdir" make install
+ cd "$builddir"
+ BROOT="$pkgdir" make install
}
md5sums="e5c632e9abd517ee91f1f1cf5fb0eaf3 prayer-1.3.5.tar.gz