aboutsummaryrefslogtreecommitdiffstats
path: root/testing/procs
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-02-08 21:01:12 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-02-14 21:37:33 +0000
commit3b688d6457197778ccafda14cdd203d1362cca03 (patch)
tree4020fac284055b624cfea06e5b9065337b32f49d /testing/procs
parent26e1e59c6cfb1cfe95d5f5110808006462c611d1 (diff)
downloadaports-3b688d6457197778ccafda14cdd203d1362cca03.tar.bz2
aports-3b688d6457197778ccafda14cdd203d1362cca03.tar.xz
testing/various: enable stackprotector
On x86, the stack protector was disabled by addinsg `-fno-stack-protector` to CFLAGS. This was due to rust not passing `-lssp_nonshared` to the linker, causing build errors while linking. Rust has been patched to fix this issue, so now we can enable stack protection again.
Diffstat (limited to 'testing/procs')
-rw-r--r--testing/procs/APKBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/testing/procs/APKBUILD b/testing/procs/APKBUILD
index 88445470d7..e403d08b8d 100644
--- a/testing/procs/APKBUILD
+++ b/testing/procs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=procs
pkgver=0.9.9
-pkgrel=0
+pkgrel=1
pkgdesc="A modern replacement for ps written in Rust"
url="https://github.com/dalance/procs"
arch="x86_64 armv7 armhf !aarch64 x86 ppc64le" # limited by rust/cargo (aarch64 due to MAP_32BIT in nix package)
@@ -12,13 +12,6 @@ options="net"
makedepends="cargo"
source="$pkgname-$pkgver.tar.gz::https://github.com/dalance/procs/archive/v$pkgver.tar.gz"
-# disable stack protector on x86 due linking error in cc package
-case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
-esac
-
export CARGO_HOME="$srcdir"/cargo
build() {