aboutsummaryrefslogtreecommitdiffstats
path: root/testing/proot/APKBUILD
diff options
context:
space:
mode:
authorDaniel Santana <daniel@santana.tech>2019-03-06 00:05:32 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 22:28:41 +0000
commite5bc64161b3a4b079fa324bcb3a52e2303d17c08 (patch)
treeb08f868f6b79829b2103d7ac3a6610c6d1d07945 /testing/proot/APKBUILD
parent782370082a3feb89c862a9ecca20bd9f319e54af (diff)
downloadaports-e5bc64161b3a4b079fa324bcb3a52e2303d17c08.tar.bz2
aports-e5bc64161b3a4b079fa324bcb3a52e2303d17c08.tar.xz
testing/proot: new aport
https://proot-me.github.io/ User-space implementation of chroot, mount --bind, and binfmt_misc
Diffstat (limited to 'testing/proot/APKBUILD')
-rw-r--r--testing/proot/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/proot/APKBUILD b/testing/proot/APKBUILD
new file mode 100644
index 0000000000..136852e502
--- /dev/null
+++ b/testing/proot/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Daniel Santana <daniel@santana.tech>
+# Maintainer: Daniel Santana <daniel@santana.tech>
+pkgname=proot
+_pkgname=PRoot
+pkgver=5.1.0_git20190306
+_sha=a6db8746f21a2e68a8d0290a0aa9b3ad36d78f56 # contain musl fixes
+pkgrel=0
+pkgdesc="User-space implementation of chroot, mount --bind, and binfmt_misc"
+url="https://proot-me.github.io"
+arch="all"
+license="GPL-2-or-later"
+makedepends="bsd-compat-headers linux-headers libarchive-dev talloc-dev"
+subpackages="$pkgname-doc $pkgname-static"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/proot-me/PRoot/archive/$_sha.tar.gz"
+builddir="$srcdir/$_pkgname-$_sha"
+options="!check" # several tests are failing
+
+build() {
+ cd "$builddir"/src
+ make proot proot.static
+}
+
+package() {
+ install -Dm 0755 "$builddir"/src/proot "$pkgdir"/usr/bin/proot
+ install -Dm 0644 "$builddir"/doc/proot/man.1 "$pkgdir"/usr/share/man/man1/proot.1
+}
+
+static() {
+ install -Dm 0755 "$builddir"/src/proot.static "$subpkgdir"/usr/bin/proot.static
+}
+
+sha512sums="956a4213cf6915a925fd1715bf26f7b531e0c45b70893db39aa760979952d7a8777d67a9976732884939e04c61975a913a1989afa9246c4c0d01a4ec9d825c55 PRoot-5.1.0_git20190306.tar.gz"