aboutsummaryrefslogtreecommitdiffstats
path: root/testing/prosody
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-11-20 11:12:24 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-11-20 11:12:50 +0100
commit28a12b6b5c39322139cae623abbd89265ae3b53b (patch)
treeac8f3d330abfbe19303ff271234fcca16544e0e4 /testing/prosody
parent3b0730c0c3d119424255c080e8edb1de61448116 (diff)
downloadaports-28a12b6b5c39322139cae623abbd89265ae3b53b.tar.bz2
aports-28a12b6b5c39322139cae623abbd89265ae3b53b.tar.xz
testing/prosody: upgrade to 0.9.2
Diffstat (limited to 'testing/prosody')
-rw-r--r--testing/prosody/APKBUILD12
-rw-r--r--testing/prosody/prosody.cfg.lua.patch40
2 files changed, 30 insertions, 22 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index a47078ce39..10915084f0 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=prosody
-pkgver=0.8.2
+pkgver=0.9.1
pkgrel=1
pkgdesc="Lua based Jabber/XMPP server"
url="http://prosody.im/"
@@ -39,6 +39,12 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="6e907bf0d0acf24f1011083020ba6ffb prosody-0.8.2.tar.gz
-5a415bb85fb1e00a17cb3ad951e3b889 prosody.cfg.lua.patch
+md5sums="e6e25eec2208409214c3a45366adc1a5 prosody-0.9.1.tar.gz
+a21d6a6efef8a08ae21109c2aa9c2fc7 prosody.cfg.lua.patch
9b68b81deb2148a3a6c3b5d2eb9c96b9 prosody.initd"
+sha256sums="6cdea6fd6027bec621f7995709ca825a29aa5e066b321bfbb7785925c9f32cd5 prosody-0.9.1.tar.gz
+db37b1b6bcd648f264164c5db5e754fc077671c74df6079c101384e146f4d6da prosody.cfg.lua.patch
+0db9babd65354fe8693d1233945da61ebbea525915f881cf601211110ea50b08 prosody.initd"
+sha512sums="dbd0d8476f0abb4030f8c1ac68786cde2dd68bc2e6602ba8ea27b7d23f2010f963dd3ff50e0a6e7780bddfba014c7bbd1fa0c607d070d979131c15431e04c3fa prosody-0.9.1.tar.gz
+6de138346c10388e986e26b6caae75291c6c19bf168ccb9daef2ac08a9d4cd1d5cfa74438e89316303ba2956a25eec8b3db23ced9fa2763cf9d8387116677001 prosody.cfg.lua.patch
+95f46dde7e066a93429c46a8ac42698af3754ebe0ed89c7dc86fad042d68264695f4270ecc5a9dabec2b5c2f989928e50b0556ccbcc513ff73ddbb5e01b47dfe prosody.initd"
diff --git a/testing/prosody/prosody.cfg.lua.patch b/testing/prosody/prosody.cfg.lua.patch
index ca1c9b331f..9b837c85b5 100644
--- a/testing/prosody/prosody.cfg.lua.patch
+++ b/testing/prosody/prosody.cfg.lua.patch
@@ -1,32 +1,34 @@
---- prosody.cfg.lua.org
-+++ prosody.cfg.lua
-@@ -22,6 +22,9 @@
- -- Example: admins = { "user1@example.com", "user2@example.net" }
- admins = { }
+diff -wbBur prosody-0.9.0.q/prosody.cfg.lua.dist prosody-0.9.0/prosody.cfg.lua.dist
+--- prosody-0.9.0.q/prosody.cfg.lua.dist 2013-08-19 23:37:36.000000000 +0400
++++ prosody-0.9.0/prosody.cfg.lua.dist 2013-08-21 16:17:49.175521891 +0400
+@@ -11,6 +11,8 @@
+ -- The only thing left to do is rename this file to remove the .dist ending, and fill in the
+ -- blanks. Good luck, and happy Jabbering!
-+daemonize = true;
-+pidfile = "/var/run/prosody/prosody.pid";
-+
- -- Enable use of libevent for better performance under high load
- -- For more information see: http://prosody.im/doc/libevent
- --use_libevent = true;
-@@ -59,7 +62,7 @@
- --"admin_telnet"; -- Opens telnet console interface on localhost port 5582
++daemonize = true
++pidfile = "/run/prosody/prosody.pid"
+
+ ---------- Server-wide settings ----------
+ -- Settings in this section apply to the whole server and are the default settings
+@@ -63,7 +65,7 @@
+ --"http_files"; -- Serve static files from a directory over HTTP
-- Other specific functionality
- --"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
+ "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
- --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
- --"httpserver"; -- Serve static files from a directory over HTTP
--"groups"; -- Shared roster support
-@@ -123,8 +126,8 @@
+ --"announce"; -- Send announcement to all online users
+ --"welcome"; -- Welcome users who register accounts
+@@ -139,9 +141,9 @@
-- Logging configuration
-- For advanced logging see http://prosody.im/doc/logging
log = {
- info = "prosody.log"; -- Change 'info' to 'debug' for verbose logging
- error = "prosody.err";
-+ info = "/var/log/prosody.log"; -- Change 'info' to 'debug' for verbose logging
-+ error = "/var/log/prosody.err";
- -- "*syslog"; -- Uncomment this for logging to syslog
+- -- "*syslog"; -- Uncomment this for logging to syslog
++ -- info = "prosody.log"; -- Change 'info' to 'debug' for verbose logging
++ -- error = "prosody.err";
++ "*syslog"; -- Uncomment this for logging to syslog
-- "*console"; -- Log to the console, useful for debugging with daemonize=false
}
+