aboutsummaryrefslogtreecommitdiffstats
path: root/testing/prosody
diff options
context:
space:
mode:
authorMika Havela <mika.havela@gmail.com>2011-08-13 15:02:45 +0000
committerMika Havela <mika.havela@gmail.com>2011-08-15 16:02:36 +0000
commit9f671feee05e2ac8da716d5a466cd4358a52cf3d (patch)
tree2dae0fb432734e5deb8db5f3865a4e7581655117 /testing/prosody
parent3a3fa35fadd11ac3025c02db19ce6a3cac3ee92d (diff)
downloadaports-9f671feee05e2ac8da716d5a466cd4358a52cf3d.tar.bz2
aports-9f671feee05e2ac8da716d5a466cd4358a52cf3d.tar.xz
testing/prosody: Upgrade to 0.8.2
Using original prosody.cfg.lua config and patch it
Diffstat (limited to 'testing/prosody')
-rw-r--r--testing/prosody/APKBUILD11
-rw-r--r--testing/prosody/prosody.cfg.lua107
-rw-r--r--testing/prosody/prosody.cfg.lua.patch32
3 files changed, 38 insertions, 112 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index 0f7b02bc75..4672f435ba 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=prosody
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=0
pkgdesc="Lua based Jabber/XMPP server"
url="http://prosody.im/"
arch="all"
license="MIT"
-depends="lua-socket lua-expat"
+depends="lua-socket lua-expat lua-filesystem lua-sec"
makedepends="lua-dev libidn-dev openssl-dev"
install="prosody.pre-install prosody.post-install"
subpackages=""
source="http://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
- $pkgname.cfg.lua
+ $pkgname.cfg.lua.patch
$pkgname.initd
"
@@ -33,11 +33,12 @@ package() {
install -d "$pkgdir/var/log/prosody" || return 1
install -d "$pkgdir/var/run/prosody" || return 1
+ patch "$pkgdir/etc/prosody/prosody.cfg.lua" "$srcdir/prosody.cfg.lua.patch" || return 1
install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="2be3e9deed0b96f109efc5707d7728ba prosody-0.8.1.tar.gz
-f42039e5a342fe62cd7e491546338aaa prosody.cfg.lua
+md5sums="6e907bf0d0acf24f1011083020ba6ffb prosody-0.8.2.tar.gz
+5a415bb85fb1e00a17cb3ad951e3b889 prosody.cfg.lua.patch
c0e647e872e30f71fa03faab189ae287 prosody.initd"
diff --git a/testing/prosody/prosody.cfg.lua b/testing/prosody/prosody.cfg.lua
deleted file mode 100644
index 99df66add6..0000000000
--- a/testing/prosody/prosody.cfg.lua
+++ /dev/null
@@ -1,107 +0,0 @@
--- Prosody Configuration File
---
--- If it wasn't already obvious, -- starts a comment, and all text after it on
--- a line is ignored by Prosody.
---
--- The config is split into sections, a global section, and one for each
--- defined host that we serve. You can add as many host sections as you like.
---
--- Lists are written { "like", "this", "one" }
--- Lists can also be of { 1, 2, 3 } numbers, etc.
--- Either commas, or semi-colons; may be used as seperators.
---
--- A table is a list of values, except each value has a name. An example would
--- be:
---
--- logging = { type = "html", directory = "/var/logs", rotate = "daily" }
---
--- Whitespace (that is tabs, spaces, line breaks) is mostly insignificant, so
--- can
--- be placed anywhere
--- that you deem fitting.
---
--- Tip: You can check that the syntax of this file is correct when you have
--- finished by running: luac -p prosody.cfg.lua
--- If there are any errors, it will let you know what and where they are,
--- otherwise it will keep quiet.
---
--- Good luck, and happy Jabbering!
-
--- Global settings go in this section
-Host "*"
- -- This is the list of modules Prosody will load on startup.
- -- It looks for mod_modulename.lua in the plugins folder, so make sure that
- -- exists too.
- modules_enabled = {
- -- Generally required
- "roster"; -- Allow users to have a roster. Recommended ;)
- "saslauth"; -- Authentication for clients and servers. Recommended
- -- if you want to log in.
- "tls"; -- Add support for secure TLS on c2s/s2s connections
- "dialback"; -- s2s dialback support
- "disco"; -- Service discovery
-
- -- Not essential, but recommended
- "private"; -- Private XML storage (for room bookmarks, etc.)
- "vcard"; -- Allow users to set vCards
-
- -- Nice to have
- "legacyauth"; -- Legacy authentication. Only used by some old
- -- clients and bots.
- "version"; -- Replies to server version requests
- "uptime"; -- Report how long server has been running
- "time"; -- Let others know the time here on this server
- "ping"; -- Replies to XMPP pings with pongs
-
- -- Required for daemonizing and logging
- "posix"; -- POSIX functionality, sends server to background,
- -- enables syslog, etc.
-
- -- Other specific functionality
- "register"; -- Allow users to register on this server using a
- -- client
- --"console"; -- telnet to port 5582 (needs console_enabled = true)
- --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
- --"httpserver"; -- Serve static files from a directory over HTTP
- }
-
- -- These are the SSL/TLS-related settings. If you don't want to use
- -- SSL/TLS, you may comment or remove this
- --ssl = {
- -- key = "/etc/prosody/certs/localhost.key";
- -- certificate = "/etc/prosody/certs/localhost.cert";
- --}
-
- log = {
- -- Log all error messages to prosody.err
- { levels = { min = "error" }, to = "file", timestamps = true,
- filename = "/var/log/prosody/prosody.err" };
- -- Log everything of level "info" and higher (that is, all except
- -- "debug" messages) to prosody.log
- { levels = { min = "info" }, to = "file", timestamps = true,
- filename = "/var/log/prosody/prosody.log" };
- }
-
- -- Required for proper daemonization support
- pidfile = "/var/run/prosody/prosody.pid"
-
--- This allows clients to connect to localhost. No harm in it.
-Host "localhost"
-
--- Section for example.com
--- (replace example.com with your domain name)
-Host "example.com"
- -- Assign this host a certificate for TLS, otherwise it would use the one
- -- set in the global section (if any).
- -- Note that old-style SSL on port 5223 only supports one certificate, and
- -- will always use the global one.
- --ssl = {
- -- key = "/etc/prosody/certs/example.com.key";
- -- certificate = "/etc/prosody/certs/example.com.crt";
- --}
-
- enabled = false -- This will disable the host, preserving the config, but
- -- denying connections
-
--- Set up a MUC (multi-user chat) room server on conference.localhost:
-Component "conference.localhost" "muc"
diff --git a/testing/prosody/prosody.cfg.lua.patch b/testing/prosody/prosody.cfg.lua.patch
new file mode 100644
index 0000000000..ca1c9b331f
--- /dev/null
+++ b/testing/prosody/prosody.cfg.lua.patch
@@ -0,0 +1,32 @@
+--- prosody.cfg.lua.org
++++ prosody.cfg.lua
+@@ -22,6 +22,9 @@
+ -- Example: admins = { "user1@example.com", "user2@example.net" }
+ admins = { }
+
++daemonize = true;
++pidfile = "/var/run/prosody/prosody.pid";
++
+ -- Enable use of libevent for better performance under high load
+ -- For more information see: http://prosody.im/doc/libevent
+ --use_libevent = true;
+@@ -59,7 +62,7 @@
+ --"admin_telnet"; -- Opens telnet console interface on localhost port 5582
+
+ -- Other specific functionality
+- --"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
++ "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
+ --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
+ --"httpserver"; -- Serve static files from a directory over HTTP
+ --"groups"; -- Shared roster support
+@@ -123,8 +126,8 @@
+ -- Logging configuration
+ -- For advanced logging see http://prosody.im/doc/logging
+ log = {
+- info = "prosody.log"; -- Change 'info' to 'debug' for verbose logging
+- error = "prosody.err";
++ info = "/var/log/prosody.log"; -- Change 'info' to 'debug' for verbose logging
++ error = "/var/log/prosody.err";
+ -- "*syslog"; -- Uncomment this for logging to syslog
+ -- "*console"; -- Log to the console, useful for debugging with daemonize=false
+ }