aboutsummaryrefslogtreecommitdiffstats
path: root/testing/psad/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-06-30 13:51:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-07-01 07:17:12 +0000
commit03556f718db92c9f24a2c288be5a3e4398a2dae7 (patch)
tree7cced5ded24eb237c2853d21d43aab1e38ee81e6 /testing/psad/APKBUILD
parentf1e674252b8076c4488154466ef146a88b946e3b (diff)
downloadaports-03556f718db92c9f24a2c288be5a3e4398a2dae7.tar.bz2
aports-03556f718db92c9f24a2c288be5a3e4398a2dae7.tar.xz
testing/psad: temporarily disable whois lookups
At the moment whois lookups trigger reboots on Alpine 3.1 & 3.2 so I don't think it's related to the new OpenRC version. Have raised an issue on github.
Diffstat (limited to 'testing/psad/APKBUILD')
-rw-r--r--testing/psad/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/psad/APKBUILD b/testing/psad/APKBUILD
index 0815c568bb..e1cf8dedd9 100644
--- a/testing/psad/APKBUILD
+++ b/testing/psad/APKBUILD
@@ -2,12 +2,13 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=psad
pkgver=2.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="3 lightweight system daemons that analyze iptables log messages to detect port scans and other suspicious traffic"
url="http://cipherdyne.org/psad/"
arch="all"
license="GPL"
-depends="perl iptables ip6tables ssmtp mailx psmisc perl-bit-vector perl-date-calc perl-iptables-chainmgr perl-iptables-parse perl-net-ipv4addr perl-unix-syslog net-tools"
+depends="perl iptables ip6tables ssmtp mailx psmisc perl-bit-vector perl-date-calc perl-iptables-chainmgr \
+ perl-iptables-parse perl-net-ipv4addr perl-unix-syslog net-tools"
subpackages="$pkgname-doc"
source="http://cipherdyne.org/psad/download/$pkgname-nodeps-$pkgver.tar.gz
psad.initd
@@ -84,7 +85,7 @@ package() {
chmod -R o+r $pkgdir/usr/sbin/*
chmod 0700 $pkgdir/var/lib/psad
#remove whois symbolic link
- rm -rf $pkgdir/usr/bin/whois
+ rm f $pkgdir/usr/bin/whois
# Fix the config
sed -e "s|$pkgdir||" $pkgdir/etc/psad/psad.conf -i
@@ -95,6 +96,9 @@ package() {
"$pkgdir"/etc/init.d/$pkgname || return 1
install -m644 -D "$srcdir"/$pkgname.confd \
"$pkgdir"/etc/conf.d/$pkgname || return 1
+
+ # temporarily disable whois lookups https://github.com/mrash/psad/issues/22
+ sed -i 's|ENABLE_WHOIS_LOOKUPS Y;|ENABLE_WHOIS_LOOKUPS N;|' "$pkgdir"/etc/psad/psad.conf
}
md5sums="acbb0ab7ae9a983386b8baee2a51b929 psad-nodeps-2.4.1.tar.gz