aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pwauth
diff options
context:
space:
mode:
authorNHellFire <nathan.renniewaldock@gmail.com>2017-05-20 06:39:48 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 19:53:08 +0000
commit43075882a85a07bbf982041df6b593ac13df6a08 (patch)
tree2f7961458790c42e11c565635bfffc98083861ee /testing/pwauth
parent47084181b5e67ebb55c17adb6b276bb8fcde8ce6 (diff)
downloadaports-43075882a85a07bbf982041df6b593ac13df6a08.tar.bz2
aports-43075882a85a07bbf982041df6b593ac13df6a08.tar.xz
testing/pwauth: new aport
https://code.google.com/p/pwauth/ Authenticator for mod_authnz_external and Apache
Diffstat (limited to 'testing/pwauth')
-rw-r--r--testing/pwauth/10-config.patch42
-rw-r--r--testing/pwauth/20-fix-warnings.patch25
-rw-r--r--testing/pwauth/APKBUILD45
3 files changed, 112 insertions, 0 deletions
diff --git a/testing/pwauth/10-config.patch b/testing/pwauth/10-config.patch
new file mode 100644
index 0000000000..a56d1bf6d4
--- /dev/null
+++ b/testing/pwauth/10-config.patch
@@ -0,0 +1,42 @@
+--- pwauth-2.3.11.orig/config.h
++++ pwauth-2.3.11/config.h
+@@ -213,8 +213,8 @@
+ * uid numbers.
+ */
+
+-#define UNIX_LASTLOG /**/
+-#define HAVE_LASTLOG_H /**/
++/* #define UNIX_LASTLOG /**/
++/* #define HAVE_LASTLOG_H /**/
+
+
+ /* If NOLOGIN_FILE is defined to the full path name of a file, then the
+@@ -227,8 +227,8 @@
+ * right with PAM.
+ */
+
+-#define NOLOGIN_FILE "/etc/nologin" /**/
+-#define MIN_NOLOGIN_UID 1 /**/
++/* #define NOLOGIN_FILE "/etc/nologin" /**/
++/* #define MIN_NOLOGIN_UID 1 /**/
+
+
+ /* Defining CHECK_LOGIN_EXPIRATION and CHECK_PASSWORD_EXPIRATION causes
+@@ -279,7 +279,7 @@
+ * to change the uid list.
+ */
+
+-#define SERVER_UIDS 30 /* user "wwwrun" on the author's system */
++/* #define SERVER_UIDS 30 /* user "wwwrun" on the author's system */
+
+
+ /* If MIN_UNIX_UID is defined to an integer, logins with uid numbers less than
+@@ -320,7 +320,7 @@
+ * SLEEP_LOCK. SLEEP_TIME defaults to 2 seconds if not defined.
+ */
+
+-#define SLEEP_LOCK "/var/run/pwauth.lock"
++/* #define SLEEP_LOCK "/var/run/pwauth.lock" */
+
+
+ /* If ENV_METHOD is defined, pwauth expects mod_auth_external to be configured
diff --git a/testing/pwauth/20-fix-warnings.patch b/testing/pwauth/20-fix-warnings.patch
new file mode 100644
index 0000000000..f57fb75712
--- /dev/null
+++ b/testing/pwauth/20-fix-warnings.patch
@@ -0,0 +1,25 @@
+--- pwauth-2.3.11.orig/auth_sun.c
++++ pwauth-2.3.11/auth_sun.c
+@@ -32,6 +32,9 @@
+ */
+
+ #include "pwauth.h"
++#if defined(CHECK_LOGIN_EXPIRATION) || defined(CHECK_PASSWORD_EXPIRATION)
++#include <time.h>
++#endif
+
+ #ifdef SHADOW_SUN
+ #ifdef NEED_UID
+--- pwauth-2.3.11.orig/main.c
++++ pwauth-2.3.11/main.c
+@@ -43,8 +43,9 @@
+ int server_uids[]= {SERVER_UIDS, 0};
+ #endif
+
++int check_auth(char *login, char *passwd);
+
+-main(int argc, char **argv)
++void main(int argc, char **argv)
+ {
+ #ifdef ENV_METHOD
+ char *login, *passwd;
diff --git a/testing/pwauth/APKBUILD b/testing/pwauth/APKBUILD
new file mode 100644
index 0000000000..6d80799e2e
--- /dev/null
+++ b/testing/pwauth/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Nathan Rennie-Waldock <nathan.renniewaldock@gmail.com>
+# Maintainer: Nathan Rennie-Waldock <nathan.renniewaldock@gmail.com>
+pkgname=pwauth
+pkgver=2.3.11
+pkgrel=0
+pkgdesc="Authenticator for mod_authnz_external and Apache"
+url="https://code.google.com/p/pwauth/"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/pwauth/$pkgname-$pkgver.tar.gz
+ 10-config.patch
+ 20-fix-warnings.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="suid"
+
+build() {
+ cd "$builddir"
+ make || return 1
+
+}
+
+package() {
+ cd "$builddir"
+ install -Dm4755 pwauth "$pkgdir/usr/sbin/pwauth" || return 1
+
+ local f
+ for f in unixgroup INSTALL FORM_AUTH; do
+ install -Dm644 "$f" \
+ "$pkgdir/usr/share/doc/$pkgname/$f" || return 1
+ done
+}
+
+md5sums="2b7812724653bb0d238c1e0dfd5affdf pwauth-2.3.11.tar.gz
+600659893382e312a8913bbee0b029c2 10-config.patch
+5e1acececae370456b5eba73f5120ae2 20-fix-warnings.patch"
+sha256sums="3c6ab789d6ec92984954b4217418781508df393639adc32514d8491d8825fa22 pwauth-2.3.11.tar.gz
+beb10f416e5ae9515bdc58af15b50ed05fa93808197ee9253b8937e8feb36597 10-config.patch
+ecc8bd1fc8e1525614f5d8ab7597cf19eac9e58bece07de0a5c145a16ede46cb 20-fix-warnings.patch"
+sha512sums="e34542179785600262d046aa2d49f3fb3980ab5506e8108081c869617aa750adeee976ce9d3496fcb8e96150dddfc69bc240970865d6955e458152d72c1c8bc7 pwauth-2.3.11.tar.gz
+8a04786d8cdf51af75fac1a0baa7a75fdb7c4cd5ef3f846a8d865f2d105013543392e11b0ba59a4ef487c6e69ac38876f892d44c1feb1c349b9674b66c1dd5b8 10-config.patch
+37820302838297b73a5c2ad571f5872136cb76a18f6af88ff0a0681b4d0d030b9d94b6025c3ad1f7128114e0b369c668c30a022c4f1ce4273c698d7c75ac9e79 20-fix-warnings.patch"