aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-anyjson
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-12 16:51:10 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 13:08:23 +0200
commit69ba73800be31622e538f4e706bf3241b1cf305f (patch)
treee4493e5f54c6a069ad3de98f6cc44760585cb5fe /testing/py-anyjson
parentad5cbd38d8ac5718e70e0aade9b367265a5a3ac6 (diff)
downloadaports-69ba73800be31622e538f4e706bf3241b1cf305f.tar.bz2
aports-69ba73800be31622e538f4e706bf3241b1cf305f.tar.xz
testing/py-anyjson: new aport
Wraps the best available JSON implementation available in a common interface https://bitbucket.org/runeh/anyjson/
Diffstat (limited to 'testing/py-anyjson')
-rw-r--r--testing/py-anyjson/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-anyjson/APKBUILD b/testing/py-anyjson/APKBUILD
new file mode 100644
index 0000000000..42688795d3
--- /dev/null
+++ b/testing/py-anyjson/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-anyjson
+_pkgname=anyjson
+pkgver=0.3.3
+pkgrel=0
+pkgdesc="Wraps the best available JSON implementation available in a common interface"
+url="https://bitbucket.org/runeh/anyjson/"
+arch="noarch"
+license="BSD"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="2ea28d6ec311aeeebaf993cb3008b27c anyjson-0.3.3.tar.gz"
+sha256sums="37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba anyjson-0.3.3.tar.gz"
+sha512sums="9e70df3cb8bfe2348fdb0eb03cf3c33ca5a1171aca6467787fc28c161354b5ebe89b2f73badfa00708774d6825799860493ddcac7f5da8cc9c251b92b5a343bc anyjson-0.3.3.tar.gz"