aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-beautifulsoup4
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
commita39e19f96447a409ae6f6c1c63d3c16feb1a3991 (patch)
tree148fdebc95bfd8788f91996703d2094c1b8df4da /testing/py-beautifulsoup4
parentc5240dc4d2a5efc26b94c943d87848e51ba2794b (diff)
downloadaports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.bz2
aports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.xz
unmaintained/[multiple] move back packages to testing
move back packages that are depends of other packages in testing
Diffstat (limited to 'testing/py-beautifulsoup4')
-rw-r--r--testing/py-beautifulsoup4/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-beautifulsoup4/APKBUILD b/testing/py-beautifulsoup4/APKBUILD
new file mode 100644
index 0000000000..1d41e2d6c6
--- /dev/null
+++ b/testing/py-beautifulsoup4/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-beautifulsoup4
+_pkgname=beautifulsoup4
+pkgver=4.3.2
+pkgrel=0
+pkgdesc="A Python HTML/XML parser"
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver:0:3}/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b8d157a204d56512a4cc196e53e7d8ee beautifulsoup4-4.3.2.tar.gz"
+sha256sums="a2b29bd048ca2fe54a046b29770964738872a9747003a371344a93eedf7ad58e beautifulsoup4-4.3.2.tar.gz"
+sha512sums="3d55e553a1a2109378e2961a0feb23a8f038f4ff7bd335a21a26d588d39761f6735888e6ca2d001587e9a6a3b8259a1a09b92b310aa17e9b76fd85601a1ca592 beautifulsoup4-4.3.2.tar.gz"