aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-rest
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-04-16 16:11:12 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-05-09 07:40:25 +0000
commit0b0d9a059131071d24542c54c812d595cc72f492 (patch)
tree4281a369903e2614cd64f49568320ed4490cafaa /testing/py-bottle-rest
parentd623b0916407341cc91e247e4b5f496e15b24a42 (diff)
downloadaports-0b0d9a059131071d24542c54c812d595cc72f492.tar.bz2
aports-0b0d9a059131071d24542c54c812d595cc72f492.tar.xz
testing/py-bottle-rest: new aport
Decorators to make REST easier in Bottle https://pypi.python.org/pypi/bottle-rest
Diffstat (limited to 'testing/py-bottle-rest')
-rw-r--r--testing/py-bottle-rest/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-rest/APKBUILD b/testing/py-bottle-rest/APKBUILD
new file mode 100644
index 0000000000..b3dab58b97
--- /dev/null
+++ b/testing/py-bottle-rest/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-rest
+_pkgname=bottle-rest
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="A decorator for REST in Bottle"
+url="https://pypi.python.org/pypi/bottle-rest/"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c69d0a1e21919718d6bce371311cb36a bottle-rest-0.4.0.tar.gz"
+sha256sums="ec50a134efc64b1ae330a6f024633756f2f866cbc265152d645104897060d423 bottle-rest-0.4.0.tar.gz"
+sha512sums="3a11d84ea3426ed3aff3036bef00b0277c90495659f8faba7fd2b08e853d2557f6726325df565d3181a8fb27314ccaf52336a540f860435f0acbd513727902b2 bottle-rest-0.4.0.tar.gz"