aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-cheetah
diff options
context:
space:
mode:
authorMatt Dainty <matt+alpine@bodgit-n-scarper.com>2016-03-24 16:33:21 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-25 12:06:14 +0000
commit42d9e69854fd28118823101411532215e787b826 (patch)
tree593a6af41cd9cc74cf17a77e2982d798c61149ff /testing/py-cheetah
parent8e5a17a8a83990c65e190d87b327a05dcb76caa7 (diff)
downloadaports-42d9e69854fd28118823101411532215e787b826.tar.bz2
aports-42d9e69854fd28118823101411532215e787b826.tar.xz
testing/py-cheetah: new aport
http://www.cheetahtemplate.org/ Cheetah is a template engine and code generation tool
Diffstat (limited to 'testing/py-cheetah')
-rw-r--r--testing/py-cheetah/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-cheetah/APKBUILD b/testing/py-cheetah/APKBUILD
new file mode 100644
index 0000000000..0c049815f0
--- /dev/null
+++ b/testing/py-cheetah/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
+# Maintainer:
+pkgname=py-cheetah
+_pkgname=Cheetah
+pkgver=2.4.4
+pkgrel=0
+pkgdesc="Cheetah is a template engine and code generation tool"
+url="http://www.cheetahtemplate.org/"
+arch="all"
+license="MIT"
+depends="python"
+makedepends="python-dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="853917116e731afbc8c8a43c37e6ddba Cheetah-2.4.4.tar.gz"
+sha256sums="be308229f0c1e5e5af4f27d7ee06d90bb19e6af3059794e5fd536a6f29a9b550 Cheetah-2.4.4.tar.gz"
+sha512sums="11b8cbf7d71789d6ae83596b133ddbe0bf1ccf2bca4c59562e7cd1d9bb75fa9d3208c0021d7d77edafdb03fd399cf1a26c003267fbffb94f27bf4457b0f9234c Cheetah-2.4.4.tar.gz"