aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-cli_helpers
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2017-07-21 08:22:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 11:15:05 +0000
commitbe6abda942b4555345e9800685de58362c2d5052 (patch)
tree670060146a6f72b118181a515e94bd4c95b698d6 /testing/py-cli_helpers
parent751dedafffacd0aff9bea0a2ccea5f9adbed055a (diff)
downloadaports-be6abda942b4555345e9800685de58362c2d5052.tar.bz2
aports-be6abda942b4555345e9800685de58362c2d5052.tar.xz
testing/py-cli_helpers: new aport
This new package is required for the update of mycli/pgcli
Diffstat (limited to 'testing/py-cli_helpers')
-rw-r--r--testing/py-cli_helpers/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/py-cli_helpers/APKBUILD b/testing/py-cli_helpers/APKBUILD
new file mode 100644
index 0000000000..f59094d863
--- /dev/null
+++ b/testing/py-cli_helpers/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-cli_helpers
+_pkgname=cli_helpers
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="A helper library for command-line interfaces"
+url="https://pypi.python.org/pypi/cli-helpers"
+arch="noarch"
+license="BSD"
+depends="py-terminaltables py-backports-csv"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="a0a0db3bd83ae366ae5e5fcd249fa19c758c6d5ddacfb7f248c868e28033fffc0e5eaf5ee7e4251a05f1a333a982a887c2cce014806a570b9a87ee1e1f8a9460 py-cli_helpers-0.2.2.tar.gz"