aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-cli_helpers
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-09-19 06:11:28 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-09-19 06:20:21 +0300
commit276ea5fb48afe309d6e641d94c341b05c22995f4 (patch)
tree84d4d84e9adedbd036290152fdef164dae68a2f1 /testing/py-cli_helpers
parent4ffd88e219ca12ba0be510fad746e800530c8cce (diff)
downloadaports-276ea5fb48afe309d6e641d94c341b05c22995f4.tar.bz2
aports-276ea5fb48afe309d6e641d94c341b05c22995f4.tar.xz
testing/py-cli_helpers: fix dependencies and enable tests
Diffstat (limited to 'testing/py-cli_helpers')
-rw-r--r--testing/py-cli_helpers/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/py-cli_helpers/APKBUILD b/testing/py-cli_helpers/APKBUILD
index 3a06de42d4..e7143920e7 100644
--- a/testing/py-cli_helpers/APKBUILD
+++ b/testing/py-cli_helpers/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py-cli_helpers
_pkgname=cli_helpers
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A helper library for command-line interfaces"
url="https://pypi.python.org/pypi/cli-helpers"
arch="noarch"
license="BSD"
-depends="py-terminaltables py-backports-csv"
+depends="py-terminaltables py-backports-csv py-tabulate"
makedepends="python2-dev py-setuptools python3-dev"
+checkdepends="pytest py-wcwidth"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,6 +19,8 @@ check() {
cd "$builddir"
python2 setup.py check
python3 setup.py check
+ py.test-2
+ py.test-3
}
build() {