aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-country/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-04-16 14:54:50 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-05-09 07:40:21 +0000
commita920c85f965a7ad363a07fd603f5bda1ffa656db (patch)
tree41677166e419b51d8671efe9edab9fa5981e67e5 /testing/py-country/APKBUILD
parent925b6ead539ac8aeda5e0b01149cb0d8c1714b37 (diff)
downloadaports-a920c85f965a7ad363a07fd603f5bda1ffa656db.tar.bz2
aports-a920c85f965a7ad363a07fd603f5bda1ffa656db.tar.xz
testing/py-country: specify license
Diffstat (limited to 'testing/py-country/APKBUILD')
-rw-r--r--testing/py-country/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/py-country/APKBUILD b/testing/py-country/APKBUILD
index cb82b2bc0f..041cec243f 100644
--- a/testing/py-country/APKBUILD
+++ b/testing/py-country/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-# Maintainer:
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-country
+_pkgname=pycountry
pkgver=1.10
-pkgrel=0
+pkgrel=1
pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
url=https://pypi.python.org/pypi/pycountry
-arch=noarch
-license=LGPL2.1
-depends=
-makedepends=py-setuptools
-source=https://pypi.python.org/packages/source/p/pycountry/pycountry-$pkgver.zip
+arch="noarch"
+license="LGPL2+"
+depends="python"
+makedepends="python-dev py-setuptools"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
-_builddir=$srcdir/pycountry-$pkgver
+_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -24,12 +25,12 @@ prepare() {
build() {
cd "$_builddir"
- python setup.py build
+ python setup.py build || return 1
}
package() {
cd "$_builddir"
- python setup.py install --root "$pkgdir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="617635a7e94dc3d18ebcb5382cd3c93f pycountry-1.10.zip"