aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-dpath
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-19 18:57:43 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-19 18:57:43 +0000
commit2cef1aff4853ec800d828493a7b2323b5e4533a6 (patch)
treea161ce4749d61ef2232411791dc613c4fd1313c2 /testing/py-dpath
parentcbff7cb1eda69cf3442bef0d77e903ec9cd8f050 (diff)
downloadaports-2cef1aff4853ec800d828493a7b2323b5e4533a6.tar.bz2
aports-2cef1aff4853ec800d828493a7b2323b5e4533a6.tar.xz
testing/py-dpath: upgrade to 1.4.2 and modernize
Diffstat (limited to 'testing/py-dpath')
-rw-r--r--testing/py-dpath/APKBUILD33
1 files changed, 9 insertions, 24 deletions
diff --git a/testing/py-dpath/APKBUILD b/testing/py-dpath/APKBUILD
index e9523c821f..8b341a38ea 100644
--- a/testing/py-dpath/APKBUILD
+++ b/testing/py-dpath/APKBUILD
@@ -2,41 +2,26 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-dpath
_pkgname=dpath
-pkgver=1.2
-_pkgsver=70
-pkgrel=0._pkgver
+pkgver=1.4.2
+pkgrel=0
pkgdesc="Filesystem-like pathing and searching for dictionaries"
url="https://www.github.com/akesterson/dpath-python"
arch="noarch"
license="MIT"
depends="python2"
-depends_dev=""
makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver-$_pkgsver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver-$_pkgsver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="adbcd66956eb40366ff00af2c7802d7e dpath-1.2-70.tar.gz"
-sha256sums="4fe5fd67f1d89b29a58bbd90ec02cac7b54472dbba5d6b0d22c4a96f105747d0 dpath-1.2-70.tar.gz"
-sha512sums="d16619b5d9568553d1ffc72fd33498198426e4755dffdbb4e6882c3f4de21fa43f58373e422d7135faee0b99cc1762b51cc15cd0dc9cf859a810d72502449df7 dpath-1.2-70.tar.gz"
+sha512sums="8b868ba63a810ef18a58a6452cf6f30eeeee44ea4bd27dbc7d0efcce116adcbb3e2793e89bf94a5aa2d8ec893f96c32dd523f102e5a0da5124a88c7d1dff00d2 dpath-1.4.2.tar.gz"