aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-elasticsearch
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-07-09 17:22:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-10 18:58:45 +0000
commitfc4ea7a20efcd4a093acb5ff42f4db527578d4fa (patch)
tree2697aebc80766ec588dcefcbd68c3ae78155fe91 /testing/py-elasticsearch
parent062d97789d0d4e037420e83c5f1349e7d062bc5d (diff)
downloadaports-fc4ea7a20efcd4a093acb5ff42f4db527578d4fa.tar.bz2
aports-fc4ea7a20efcd4a093acb5ff42f4db527578d4fa.tar.xz
testing/py-elasticsearch: new aport
Diffstat (limited to 'testing/py-elasticsearch')
-rw-r--r--testing/py-elasticsearch/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/py-elasticsearch/APKBUILD b/testing/py-elasticsearch/APKBUILD
new file mode 100644
index 0000000000..d3376f0878
--- /dev/null
+++ b/testing/py-elasticsearch/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py-elasticsearch
+_pkgname=elasticsearch-py
+pkgver=5.4.0
+pkgrel=0
+pkgdesc="Official Python low-level client for Elasticsearch"
+url="http://elasticsearch-py.rtfd.org/"
+arch="noarch"
+license="ASL-2.0"
+depends="py-urllib3"
+#checkdepends="py-requests py-nose py-coverage py-mock py-yaml py-nosexcover"
+checkdepends="py-requests py-nose py-coverage py-mock py-yaml" # add nosexcover next release
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elastic/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+sha512sums="9d30ffa810f495662769e6d2f2627f9ef6aa3849bc2eecd09df28c05a036b8fb15ae465914c38eeb3d854683bc150a3c56425388312bcd112bd5cc7b33ad41ae py-elasticsearch-5.4.0.tar.gz"