aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-qrcode
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 19:21:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 19:42:15 -0300
commit7792489e3cad8acdfa2b3810c9c82780b7721040 (patch)
treee079a0ec53a7ed094a4d0bae5b7058487905ddee /testing/py-flask-qrcode
parentcf806c0a874cdfef745c62111859ad54bafc910d (diff)
downloadaports-7792489e3cad8acdfa2b3810c9c82780b7721040.tar.bz2
aports-7792489e3cad8acdfa2b3810c9c82780b7721040.tar.xz
testing/py3-flask-qrcode: rename from py-flask-qrcode
Diffstat (limited to 'testing/py-flask-qrcode')
-rw-r--r--testing/py-flask-qrcode/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/testing/py-flask-qrcode/APKBUILD b/testing/py-flask-qrcode/APKBUILD
deleted file mode 100644
index daadf5a30c..0000000000
--- a/testing/py-flask-qrcode/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-qrcode
-_pkgname=Flask-QRcode
-pkgver=2.0.2
-pkgrel=1
-pkgdesc="Simple flask extension to render QR codes on template"
-url="https://github.com/marcoagner/Flask-QRcode"
-arch="noarch"
-license="GPL-3.0-or-later"
-depends="py-flask py-qrcode"
-depends_dev=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="c70cdb75648e74697793fc9b34a54f87adab68efdffb7f00e759ebeb7bc9c20d20a90b50dc70a19661ea5e2c98d14d9825eb483a0e1aec05504b5958638307e5 Flask-QRcode-2.0.2.tar.gz"