aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-qrcode
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-06 20:40:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 20:08:04 +0000
commit26e514b99214145d307ae36e9e1753cd19b86b37 (patch)
tree2e32bdb3bd7a5bc9d55ea5cff04587618b6453b8 /testing/py-flask-qrcode
parent7dda9d5902846976b9e2f3703c375c53158f8784 (diff)
downloadaports-26e514b99214145d307ae36e9e1753cd19b86b37.tar.bz2
aports-26e514b99214145d307ae36e9e1753cd19b86b37.tar.xz
testing/py-flask-qrcode: clarify license, improve abuild
Diffstat (limited to 'testing/py-flask-qrcode')
-rw-r--r--testing/py-flask-qrcode/APKBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/testing/py-flask-qrcode/APKBUILD b/testing/py-flask-qrcode/APKBUILD
index b06f20c41f..a1375e70be 100644
--- a/testing/py-flask-qrcode/APKBUILD
+++ b/testing/py-flask-qrcode/APKBUILD
@@ -4,10 +4,10 @@ pkgname=py-flask-qrcode
_pkgname=Flask-QRcode
pkgver=2.0.2
pkgrel=0
-pkgdesc="A simple flask extension to render QR codes on template"
+pkgdesc="Simple flask extension to render QR codes on template"
url="https://github.com/marcoagner/Flask-QRcode"
arch="noarch"
-license="BSD"
+license="GPL-3.0-or-later"
depends="py-flask py-qrcode"
depends_dev=""
makedepends="python2-dev python3-dev py-setuptools"
@@ -15,20 +15,11 @@ install=""
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
python3 setup.py build
}
@@ -53,7 +44,7 @@ _py() {
depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$_builddir"
+ cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}