aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-google-apputils
diff options
context:
space:
mode:
authorCorentin Henry <corentinhenry@gmail.com>2016-05-17 08:58:07 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-06-01 20:22:30 +0200
commit759d4ff57352f891b00f6b073883b8d12a43b0cc (patch)
treee21cb79bbbbbeb5e34f2ef9c0b920967220289df /testing/py-google-apputils
parentc3ea8c18839b3a25e5ee6e8ec9ca3cb2c7475753 (diff)
downloadaports-759d4ff57352f891b00f6b073883b8d12a43b0cc.tar.bz2
aports-759d4ff57352f891b00f6b073883b8d12a43b0cc.tar.xz
testing/py-google-apputils: new aport
Decription: collection of utilities for building Python applications Project URL: https://github.com/google/google-apputils
Diffstat (limited to 'testing/py-google-apputils')
-rw-r--r--testing/py-google-apputils/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-google-apputils/APKBUILD b/testing/py-google-apputils/APKBUILD
new file mode 100644
index 0000000000..c7f36f4e7b
--- /dev/null
+++ b/testing/py-google-apputils/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Corentin Henry <corentinhenry@gmail.com>
+# Maintainer: Corentin Henry <corentinhenry@gmail.com>
+pkgname=py-google-apputils
+_pkgname=google-apputils
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Google Application Utilities for Python"
+url="https://github.com/google/google-apputils"
+arch="noarch"
+license="ASL-2.0"
+depends="python py-dateutil>=1.4 py-gflags>=1.4 py-tz>=2010"
+makedepends="python-dev py-setuptools"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="59e19f16b9a1adb2c84987581ee8b659 google-apputils-0.4.0.tar.gz"
+sha256sums="b260eb39f2723b71329ad016773033b95a31e89d8c9e13b8e6a1ef8eed8e94a3 google-apputils-0.4.0.tar.gz"
+sha512sums="5dbbf50e9551b33d882557ef9385c64691dcff6d6c219c9ff6aea2dc73c8af6d03392b3088fe1fb4000979e227830a0e437dc347520488627657085c8ea23f5e google-apputils-0.4.0.tar.gz"