aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-greenlet
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2014-05-22 17:14:38 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2014-05-22 17:14:38 +0000
commit45f94bbadb7c0f693557ac4b7d51d4e7a832d787 (patch)
tree94d879f4ae60844f55f830521d9d50ef67095734 /testing/py-greenlet
parent1ed733745a902d573f296b5eaf088e487dfa24ed (diff)
downloadaports-45f94bbadb7c0f693557ac4b7d51d4e7a832d787.tar.bz2
aports-45f94bbadb7c0f693557ac4b7d51d4e7a832d787.tar.xz
testing/greenlet: rebuild with -O0
Diffstat (limited to 'testing/py-greenlet')
-rw-r--r--testing/py-greenlet/APKBUILD14
-rw-r--r--testing/py-greenlet/gcc-4.8-bugfix.patch16
2 files changed, 25 insertions, 5 deletions
diff --git a/testing/py-greenlet/APKBUILD b/testing/py-greenlet/APKBUILD
index 0cf668ddfb..de24c1bb99 100644
--- a/testing/py-greenlet/APKBUILD
+++ b/testing/py-greenlet/APKBUILD
@@ -3,14 +3,15 @@
pkgname=py-greenlet
_pkgname=greenlet
pkgver=0.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Lightweight in-process concurrent programming"
url="http://pypi.python.org/pypi/greenlet"
arch="all"
license="MIT"
depends=""
makedepends="python-dev py-setuptools"
-source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
+ gcc-4.8-bugfix.patch"
_builddir="$srcdir"/$_pkgname-$pkgver
build ()
@@ -24,6 +25,9 @@ package() {
python setup.py install --root="$pkgdir" || return 1
}
-md5sums="87887570082caadc08fb1f8671dbed71 greenlet-0.4.0.zip"
-sha256sums="3f52af03bf8a89045fc159c6a76d5642349b30fb41c3df1a22b12bbd3920b1ee greenlet-0.4.0.zip"
-sha512sums="c072ceb83b3040448f0f7c8596aa134837fcc2ada5513b12fbeada4f5ae2ca5e4d4c5814c317a9270e4a0a65a02e2525dce7edad678978782013da7caa188d19 greenlet-0.4.0.zip"
+md5sums="87887570082caadc08fb1f8671dbed71 greenlet-0.4.0.zip
+93c2b0229a5d6f1228396fec05b7c4e1 gcc-4.8-bugfix.patch"
+sha256sums="3f52af03bf8a89045fc159c6a76d5642349b30fb41c3df1a22b12bbd3920b1ee greenlet-0.4.0.zip
+e0f10049aa8cd205cd4c93b80bcd9cc8247be2a55e0b74b7f50841afe8eea483 gcc-4.8-bugfix.patch"
+sha512sums="c072ceb83b3040448f0f7c8596aa134837fcc2ada5513b12fbeada4f5ae2ca5e4d4c5814c317a9270e4a0a65a02e2525dce7edad678978782013da7caa188d19 greenlet-0.4.0.zip
+d7fcdf5aa207e7e94bfdf96a9f94d2ab669f46c484c6a1972c1d7dde79de1bbabf1e6f76650dfe78ea91cf977acb10975ad3d3ac3c7e4d9553a06b00c44081d1 gcc-4.8-bugfix.patch"
diff --git a/testing/py-greenlet/gcc-4.8-bugfix.patch b/testing/py-greenlet/gcc-4.8-bugfix.patch
new file mode 100644
index 0000000000..1526f3eb18
--- /dev/null
+++ b/testing/py-greenlet/gcc-4.8-bugfix.patch
@@ -0,0 +1,16 @@
+--- greenlet-0.4.0.orig/setup.py
++++ greenlet-0.4.0/setup.py
+@@ -2,12 +2,7 @@
+
+ import sys, os, glob, platform
+
+-# workaround segfaults on openbsd and RHEL 3 / CentOS 3 . see
+-# https://bitbucket.org/ambroff/greenlet/issue/11/segfault-on-openbsd-i386
+-# https://github.com/python-greenlet/greenlet/issues/4
+-if ((sys.platform == "openbsd4" and os.uname()[-1] == "i386")
+- or ("-with-redhat-3." in platform.platform() and platform.machine() == 'i686')):
+- os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "-Os")).lstrip()
++os.environ['CFLAGS'] = '-O0'
+
+ try:
+ if not (sys.modules.get("setuptools")