aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-h5py/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-13 17:17:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 17:17:00 -0300
commit6b87043ce0a9b6e11b6637465e11060057edfc50 (patch)
treece6319d95de352ec85aeed3a327a0bf364cfa680 /testing/py-h5py/APKBUILD
parentc79a34a3ad3c4f383c487439e9a79679fc718fac (diff)
downloadaports-6b87043ce0a9b6e11b6637465e11060057edfc50.tar.bz2
aports-6b87043ce0a9b6e11b6637465e11060057edfc50.tar.xz
testing/py-h5py: rebuild against hdf5-1.10.5
Diffstat (limited to 'testing/py-h5py/APKBUILD')
-rw-r--r--testing/py-h5py/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/testing/py-h5py/APKBUILD b/testing/py-h5py/APKBUILD
index f94c40d960..854dc889c8 100644
--- a/testing/py-h5py/APKBUILD
+++ b/testing/py-h5py/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-h5py
_pkgname=h5py
pkgver=2.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="Read and write HDF5 files from Python"
# ERROR: test_exc (h5py.tests.old.test_group.TestLen)
# len() on closed group gives ValueError
@@ -14,9 +14,16 @@ license="BSD-3-Clause"
depends="py-six py-numpy hdf5"
makedepends="cython python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ hdf5-1.10.5.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
+prepare() {
+ default_prepare
+ sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" setup_build.py
+}
+
build() {
python2 setup.py build
python3 setup.py build
@@ -51,4 +58,5 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="73b1f59e3e2b3eceebf7b97e49bd8f5199afafd7ef29917af05ff8415c2f2129a5c59db9658944370c9bcf8fc04ab26948ee27fc6fd948a22d19cace1ce8c853 h5py-2.9.0.tar.gz"
+sha512sums="73b1f59e3e2b3eceebf7b97e49bd8f5199afafd7ef29917af05ff8415c2f2129a5c59db9658944370c9bcf8fc04ab26948ee27fc6fd948a22d19cace1ce8c853 h5py-2.9.0.tar.gz
+8fbe88cb9aeda00702402bf10c9719d1b038f63cb788ee32639306cda26aa97f5e854ad8a0aea1d06262ed3b6df1ff4c002297565ddaade4a2865fa8beb1ef53 hdf5-1.10.5.patch"