aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-h5py
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 01:12:14 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-26 13:23:05 +0000
commit3d0c78870337974b5e9e3d922baa96671ac16105 (patch)
tree4c5ca78f5ae5b930ead2b438ecc8a89bc3f895c8 /testing/py-h5py
parentd99915c2b447035d78a5ed1d2b1ebeabbf2d796e (diff)
downloadaports-3d0c78870337974b5e9e3d922baa96671ac16105.tar.bz2
aports-3d0c78870337974b5e9e3d922baa96671ac16105.tar.xz
testing/py-h5py: modernize, fix license.
Closes GH-8118
Diffstat (limited to 'testing/py-h5py')
-rw-r--r--testing/py-h5py/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/testing/py-h5py/APKBUILD b/testing/py-h5py/APKBUILD
index 5e7d8aadb3..b20411cf66 100644
--- a/testing/py-h5py/APKBUILD
+++ b/testing/py-h5py/APKBUILD
@@ -3,24 +3,29 @@
pkgname=py-h5py
_pkgname=h5py
pkgver=2.8.0
-pkgrel=3
+pkgrel=4
pkgdesc="Read and write HDF5 files from Python"
+# ERROR: test_exc (h5py.tests.old.test_group.TestLen)
+# len() on closed group gives ValueError
+options="!check"
url="https://www.h5py.org"
arch="all !s390x"
-license="BSD"
+license="BSD-3-Clause"
depends="py-six py-numpy hdf5"
-makedepends="cython python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev py-six"
+makedepends="cython python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
-
python2 setup.py build
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
mkdir -p "$pkgdir"
}