aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-html2data
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 20:09:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:34 +0000
commit8e1f9a3b89a016be8a0957a5d8b467d442e7f483 (patch)
treef3bed4073765efe23af5e1050cbc64780b196837 /testing/py-html2data
parent91e414bba773b1ea03112d9460026661db285a64 (diff)
downloadaports-8e1f9a3b89a016be8a0957a5d8b467d442e7f483.tar.bz2
aports-8e1f9a3b89a016be8a0957a5d8b467d442e7f483.tar.xz
testing/py-html2data: new aport
A Python transformer for HTML file or URL to structured data https://github.com/dperezrada/html2data
Diffstat (limited to 'testing/py-html2data')
-rw-r--r--testing/py-html2data/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-html2data/APKBUILD b/testing/py-html2data/APKBUILD
new file mode 100644
index 0000000000..33a730e275
--- /dev/null
+++ b/testing/py-html2data/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-html2data
+_pkgname=html2data
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="A Python transformer for HTML file or URL to structured data"
+url="https://github.com/dperezrada/html2data"
+arch="noarch"
+license="BSD"
+depends="python py-lxml py-httplib2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a3710a11125fc0ce353f44e28178e9cb html2data-0.4.3.tar.gz"
+sha256sums="0c3335cadb1ac350c3a6dae571a96b45289c7dceb8de95dbe24ca9fa49199628 html2data-0.4.3.tar.gz"
+sha512sums="b001ddc229735934283e173ad3b55335d02b12524a4a7487ee505ad09a9b8d23d9c960f3e4324df1b1082fa9b18f007571a79ef3d28e7170013435f1689e567c html2data-0.4.3.tar.gz"