aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-humanize
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-07-06 10:02:40 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-07-06 18:37:10 +0200
commitaa5f5cd879af6d1f8e5d0233c655244a87a6fd6f (patch)
tree4f04d86ffc6a27143251f834d879e11946db7aa7 /testing/py-humanize
parent1f4b46699f87611ab74c8d9bc7ac9cdf5fb5ad92 (diff)
downloadaports-aa5f5cd879af6d1f8e5d0233c655244a87a6fd6f.tar.bz2
aports-aa5f5cd879af6d1f8e5d0233c655244a87a6fd6f.tar.xz
testing/py-humanize: new aport
https://pypi.python.org/pypi/humanize Python humanize functions
Diffstat (limited to 'testing/py-humanize')
-rw-r--r--testing/py-humanize/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-humanize/APKBUILD b/testing/py-humanize/APKBUILD
new file mode 100644
index 0000000000..5ce5396c6d
--- /dev/null
+++ b/testing/py-humanize/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-humanize
+_pkgname=humanize
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Python humanize functions"
+url="https://pypi.python.org/pypi/humanize"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e8473d9dc1b220911cac2edd53b1d973 py-humanize-0.5.1.tar.gz"
+sha256sums="a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19 py-humanize-0.5.1.tar.gz"
+sha512sums="2727268d9fc7b393228f7eb9e71a5c881988ec56e265ddf83613fe57116da3aaad70d2417db4cef8a8c40cb73753eb2c2bd775d3cd25c2de751cb61373f0a551 py-humanize-0.5.1.tar.gz"