aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-intervals
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-12 16:48:24 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 13:08:23 +0200
commit930332199f5931344b441f3789b659bb9d9ae487 (patch)
tree40909e8288a396c68547a4f0ecb92ac43c7e64cb /testing/py-intervals
parent404439b9a1a2826c6212e976ae6b874212afd254 (diff)
downloadaports-930332199f5931344b441f3789b659bb9d9ae487.tar.bz2
aports-930332199f5931344b441f3789b659bb9d9ae487.tar.xz
testing/py-intervals: new aport
A Python module for handling intervals (ranges of comparable objects) https://github.com/kvesteri/intervals
Diffstat (limited to 'testing/py-intervals')
-rw-r--r--testing/py-intervals/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/py-intervals/APKBUILD b/testing/py-intervals/APKBUILD
new file mode 100644
index 0000000000..da334dce54
--- /dev/null
+++ b/testing/py-intervals/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-intervals
+_pkgname=intervals
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="A Python module for handling intervals (ranges of comparable objects)"
+url="https://github.com/kvesteri/intervals"
+arch="noarch"
+license="BSD"
+depends="py-infinity"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="d2e7b132a4a00f001938cf47884b5e60 intervals-0.8.0.tar.gz"
+sha256sums="178534a1c8d2c034f1fc062e5f90cf73682101ca81470eb5741453feef830135 intervals-0.8.0.tar.gz"
+sha512sums="1953c9535c9d5dbf2080409000e9942b71416473d4856f6eb1e08e55576fce1e979d00563953afca59eed4a6ff8df2f52cf0557e88312416cf1294213e924c38 intervals-0.8.0.tar.gz"