aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-jsonpatch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-04-27 18:04:12 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-04-28 03:49:31 +0300
commit9c180cf8e685f6402c77ed63c4b2a16d4c330056 (patch)
tree94e1eb25b77e13b36b014de6231b7a6f5cc99a17 /testing/py-jsonpatch
parent1d24ae8b65d4e525835e2caf0cfbbc08a54f165a (diff)
downloadaports-9c180cf8e685f6402c77ed63c4b2a16d4c330056.tar.bz2
aports-9c180cf8e685f6402c77ed63c4b2a16d4c330056.tar.xz
testing/py-jsonpatch: upgrade to 1.23, clarify license
Diffstat (limited to 'testing/py-jsonpatch')
-rw-r--r--testing/py-jsonpatch/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/testing/py-jsonpatch/APKBUILD b/testing/py-jsonpatch/APKBUILD
index 4cd5b45c4e..bd28a9ebd1 100644
--- a/testing/py-jsonpatch/APKBUILD
+++ b/testing/py-jsonpatch/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=py-jsonpatch
_pkgname=${pkgname#py-}
-pkgver=1.16
+pkgver=1.23
pkgrel=0
pkgdesc="Apply JSON-Patches (RFC 6902)"
url="https://github.com/stefankoegl/python-json-patch"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="py-jsonpointer"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
@@ -20,6 +20,12 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
package() {
mkdir -p "$pkgdir"
}
@@ -44,4 +50,4 @@ _py3() {
depends="${depends//py-/py3-}"
_py python3
}
-sha512sums="a7f6fc3b9e741ff8bd64aa04c15c66ac218b520f17b7870068f992dab0794129fbb8a385cdc7e424814a91246110b8b24fa99a20e0d37d9bdedc3bcdc3a8c170 jsonpatch-1.16.tar.gz"
+sha512sums="da612fc043e351087fbda26cd5686743107dafca1223e784626c39113dfb4770647db1420e9ab9eee93d12c608a6e0812f0825229ab092962cfb390b6b1795ed jsonpatch-1.23.tar.gz"