aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-luhn
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 03:02:14 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 03:02:14 +0000
commita21df24acdcdd37d93f25d7fca1f4c7f26a69e72 (patch)
tree47451ab1046aea1a82c168a9d688dd9bf79cb2f6 /testing/py-luhn
parent8535867de4befb6fac5a12b77cec0e805428023c (diff)
downloadaports-a21df24acdcdd37d93f25d7fca1f4c7f26a69e72.tar.bz2
aports-a21df24acdcdd37d93f25d7fca1f4c7f26a69e72.tar.xz
testing/py-luhn: new aport
Diffstat (limited to 'testing/py-luhn')
-rw-r--r--testing/py-luhn/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-luhn/APKBUILD b/testing/py-luhn/APKBUILD
new file mode 100644
index 0000000000..ffcc441a23
--- /dev/null
+++ b/testing/py-luhn/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-luhn
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="generate and validate luhn check digits"
+url="https://pypi.python.org/pypi/luhn/"
+arch="noarch"
+license="BSD"
+depends="py-amqp"
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-luhn:py2 py3-luhn:py3"
+source="https://files.pythonhosted.org/packages/source/l/luhn/luhn-$pkgver.tar.gz"
+builddir="$srcdir/luhn-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="81c5be3ae22069f409098ad3c333e90514cfd1dd351974cabfd03981790e408bd65129f46b1a05dc9411d566c4a9ceb62b0942a276a1bb561c3b3282685b46f7 luhn-0.2.0.tar.gz"