aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-lz4/01-system_lz4.patch
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-04-24 23:23:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-05 15:31:39 +0000
commitc1a5d64686d055f0a7b2ac2cc0a53567bbcbe8a3 (patch)
treef40d5198d65d47435db5745908bb4432d317979d /testing/py-lz4/01-system_lz4.patch
parentcc7187ce9a618ff10a14c774fdb366e2ade03466 (diff)
downloadaports-c1a5d64686d055f0a7b2ac2cc0a53567bbcbe8a3.tar.bz2
aports-c1a5d64686d055f0a7b2ac2cc0a53567bbcbe8a3.tar.xz
testing/py-lz4: new aport
closes https://bugs.alpinelinux.org/issues/5480
Diffstat (limited to 'testing/py-lz4/01-system_lz4.patch')
-rw-r--r--testing/py-lz4/01-system_lz4.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py-lz4/01-system_lz4.patch b/testing/py-lz4/01-system_lz4.patch
new file mode 100644
index 0000000000..62a9c9dea9
--- /dev/null
+++ b/testing/py-lz4/01-system_lz4.patch
@@ -0,0 +1,36 @@
+Last-Update: 2014-08-10
+Forwarded: not-needed
+Author: Dmitry Smirnov <onlyjob@member.fsf.org>
+Description: un-bundle liblz4 and link to the system one
+
+--- a/setup.py
++++ b/setup.py
+@@ -16,11 +16,11 @@
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+ ext_modules=[
+ Extension('lz4', [
+- 'src/lz4.c',
+- 'src/lz4hc.c',
+ 'src/python-lz4.c'
++ ], libraries=[
++ "lz4",
+ ], extra_compile_args=[
+ "-std=c99",
+ "-O3",
+ "-Wall",
+--- a/src/python-lz4.c
++++ b/src/python-lz4.c
+@@ -32,10 +32,10 @@
+ #include <Python.h>
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <math.h>
+-#include "lz4.h"
+-#include "lz4hc.h"
++#include <lz4.h>
++#include <lz4hc.h>
+ #include "python-lz4.h"
+
+ #define MAX(a, b) ((a) > (b) ? (a) : (b))
+